Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#1728 closed defect (not a bug)

Question to research

Reported by: phobos Owned by: phobos
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Keywords: tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Is china gfw blocking in the following ways:

1) ip address of a tor relay
2) ip address and tcp port of a tor relay

A test thought up today is to setup a tor relay and change the port every week, but not the IP. What gets blocked? The IP of the relay or ip:port combination, and how long is the lag between blocking events?

Child Tickets

Change History (6)

comment:1 Changed 9 years ago by phobos

Owner: set to phobos
Status: newaccepted

Initial testing shows china is blocking IP:tcp port combination. continuing testing.

comment:2 Changed 9 years ago by arma

When they did the blocking in Sept 2009, I did a lot of scanning of each blocked relay. Some of them were blocked by IP:port, and some of the IP addresses were blackholed. I noticed a trend that relays with other services on that IP were blocked in the more fine-grained way (IP:port), whereas relays not running anything else just got blackholed.

See also http://archives.seul.org/tor/relays/Sep-2009/msg00003.html

comment:3 Changed 9 years ago by phobos

It appears the bridges i'm testing from inside china are blocked by ip:port combination. changing the port makes the bridge available again.

comment:4 Changed 9 years ago by phobos

Resolution: not a bug
Status: acceptedclosed

More confirmation that the gfw is blocking by IP:tcp port combination.

comment:5 Changed 7 years ago by nickm

Keywords: tor-relay added

comment:6 Changed 7 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.