Opened 4 years ago

Closed 4 years ago

#17328 closed enhancement (duplicate)

Use more ubiquitous value for reported screen size

Reported by: klonido Owned by: tbb-team
Priority: Very Low Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: tbb-torbutton, tbb-fingerprinting, tbb-fingerprinting-resolution
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

TorBrowser currently provides "1000x600x24" as arbitrary values for screen size. According to Panopticlick, this corresponds to 1 in 439 browsers. A more common value would be "1366x768x24" which corresponds to 1 in 16 browsers.

I am confident that changing the reported screen size to a more common value would be a (slight) anonymity improvement for individual users (since using the most ubiquitious values across all browsers makes distinguishing between them more difficult), However I cannot claim to know all the implications (like perhaps using different values between different TorBrowser versions would have negative anonymity implications for users of the new version, for example).

I imagine the screen size of 1000x600x24 is going to become less and less common as time goes on, so I would advocate chaning to the more ubiquitious value sooner rather than later.

Child Tickets

Change History (5)

comment:1 Changed 4 years ago by klonido

Component: AnalysisTor Browser
Owner: set to tbb-team

comment:2 Changed 4 years ago by klonido

Keywords: tbb-fingerprinting added; anonymity screen size removed

comment:3 Changed 4 years ago by klonido

Keywords: tbb-fingerprinting-resolution added

comment:4 Changed 4 years ago by klonido

Keywords: tbb-torbutton added

comment:5 Changed 4 years ago by elypter

Resolution: duplicate
Status: newclosed

duplicate of #4810

Note: See TracTickets for help on using tickets.