Opened 4 years ago

Closed 3 years ago

#17361 closed defect (duplicate)

Don't allow circuits with same countries

Reported by: cypherpunks Owned by: tbb-team
Priority: Very High Milestone:
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Is there a reason Tor browser allows countries to have nodes from the same country more than once within the same circuit?

As far as I know, middle+exit with same country nodes is common. I have hardly/never seen all 3 countries with the same country so I assume protection for this has already been implemented? Is the same done to make sure entry+exit nodes do not come from the same country?

Why not add that functionality for middle+exit nodes?

Child Tickets

Change History (2)

comment:1 Changed 3 years ago by cypherpunks

Priority: MediumVery High

Do something, please. It looks like sybil attack, tbb chooses all the nodes from the same country very often. Also it often (most of the time!) chooses 2 nodes from the same country. Do you use weak PRNG to select nodes?

comment:2 Changed 3 years ago by teor

Component: Tor BrowserTor
Resolution: duplicate
Status: newclosed

This is a duplicate of #3678, please read the comments there as to why this is a difficult problem to solve.

To answer your questions:

Note: See TracTickets for help on using tickets.