Opened 3 years ago

Closed 3 years ago

Last modified 7 weeks ago

#17453 closed defect (fixed)

Crashing on Windows 10

Reported by: arlolra Owned by:
Priority: High Milestone:
Component: Archived/Tor Messenger Version:
Severity: Blocker Keywords:
Cc: sukhbir, boklm, mcs Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by sukhbir)

there is a user in #tor that is reporting tor messenger crashing on windows 10
"seems it crashes inside directx dlls trying to write to a null pointer"

Workaround:

ticket:17453#comment:7

Child Tickets

Change History (20)

comment:1 Changed 3 years ago by mcs

Cc: mcs added

comment:2 Changed 3 years ago by sukhbir

Some users are also reporting issues with Windows 7.1 and 8 x64 builds. We should check with a debug build to see where the problem is.

comment:3 Changed 3 years ago by sukhbir

Severity: NormalBlocker

comment:4 Changed 3 years ago by cYphErPUNKs

I can confirm that it crashes on Win7 64-bit pro with EMET installed and using the default settings. No specific rules have been added for Instantbird, and EMET has DEP and ASLR set to always-on, and SEHOP set to application opt-out.

I am running a physical machine, but other users may be running Windows VMs.

This has been an issue for alphas #1-3 and the latest beta. I tried disabling EMET for the alphas, no luck there. I haven't tried disabling EMET for the latest beta, though.

It seems like a number of users are having this issue on many versions of Win7, 8, 8.1, 10. Most users appear to be running 64-bit Windows but at least one is running Windows 8.1 32-bit.

One user did report it working on a Windows Server 2012 R2 VM.

"On October 29th, 2015 Anonymous said:
I had posted earlier about tor messenger not working on Win 8.1. Although it works on my Win server 2012 R2 VM."

Some bug reports are showing up on the blog, and I have posted the technical details here. There are many more reports that don't have those details, and possibly more reports in forums/IRC (which I don't monitor).

From the blog (not me):

"On October 29th, 2015 Anonymous said:

Problem signature:
Problem Event Name: APPCRASH
Application Name: instantbird.exe
Application Version: 41.0.0.5729
Application Timestamp: 000232e8
Fault Module Name: d2d1.dll
Fault Module Version: 6.1.7601.17514
Fault Module Timestamp: 4ce7b7aa
Exception Code: c0000005
Exception Offset: 0001f3ba
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 2057
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789"

Another user, also not me:

"On October 29th, 2015 Anonymous said:

It doesn't work at all, Windows 7 64bit, Windows 8.1 32bit, and Windows 10 64bit.

Faulting application name: instantbird.exe, version: 41.0.0.5729, time stamp: 0x000232e8
Faulting module name: d2d1.dll, version: 6.2.9200.16765, time stamp: 0x528bf6b2
Exception code: 0xc0000005
Fault offset: 0x002284f6
Faulting process id: 0x1728
Faulting application start time: 0x01d112c2de7b0b89
Faulting application path: Tor Messenger\Messenger\instantbird.exe
Faulting module path: C:\Windows\system32\d2d1.dll
Report Id: 26f0368d-7eb6-11e5-8e12-005056c00008

Faulting application name: tormessenger-install-0.1.0b2_en-US.exe, version: 0.0.0.0, time stamp: 0x53c50d97
Faulting module name: SyncShellExtension86_70.dll, version: 0.0.0.0, time stamp: 0x560252bd
Exception code: 0xc0000005
Fault offset: 0x0000ce6e
Faulting process id: 0x1938
Faulting application start time: 0x01d112c2bdcd2844
Faulting application path: tormessenger-install-0.1.0b2_en-US.exe
Faulting module path: BitTorrent Sync\SyncShellExtension86_70.dll
Report Id: 0c5a1308-7eb6-11e5-8e12-005056c00008"

EDIT: Missed other reports:

"On October 29th, 2015 Anonymous said:
Crash
Сигнатура проблемы:
Имя события проблемы: APPCRASH
Имя приложения: instantbird.exe
Версия приложения: 41.0.0.5729
Отметка времени приложения: 000232e8
Имя модуля с ошибкой: d2d1.dll
Версия модуля с ошибкой: 6.1.7601.17514
Отметка времени модуля с ошибкой: 4ce7b7aa
Код исключения: c0000005
Смещение исключения: 0001f3ba
Версия ОС: 6.1.7601.2.1.0.256.1
Код языка: 1049
Дополнительные сведения 1: 0a9e
Дополнительные сведения 2: 0a9e372d3b4ad19135b953a78882e789
Дополнительные сведения 3: 0a9e
Дополнительные сведения 4: 0a9e372d3b4ad19135b953a78882e789"

And also:

"On October 29th, 2015 Anonymous said:

It doesn't open on my machine. It gives an error: 0x0000000070C19BD5 made reference to the memory on 0x0000000000000000. The memory can't be written.

If i launch it as admin it just loads but nothing happens, won't open and won't display any error.

Does this require something else in order to work?"
(This user mentioned running Windows 10 in a later comment)

Last edited 3 years ago by cYphErPUNKs (previous) (diff)

comment:5 Changed 3 years ago by gk

Seems like this is your version of #9145. See that ticket for workarounds. (I guess you don't set gfx.direct2d.disabled and layers.acceleration.disabled to true, right?)

comment:6 Changed 3 years ago by cYphErPUNKs

Thank you! Verified working on Win7 64-bit. Changes made to prefs.js in the tor-launcher folder, as well as the prefs.js in the default profile folder and the prefs.js in the profile folder created on first run.

(I really should have recognized this bug when I got safe mode working...three months ago. Argh!)

Last edited 3 years ago by cYphErPUNKs (previous) (diff)

comment:7 Changed 3 years ago by boklm

Thanks!

So the workaround for users who don't want to wait for the next release is to create the file Messenger/TorMessenger/Data/Browser/profile.default/prefs.js with the following two lines:

user_pref("gfx.direct2d.disabled", true);
user_pref("layers.acceleration.disabled", true);
Last edited 3 years ago by boklm (previous) (diff)

comment:8 Changed 3 years ago by sukhbir

After this was reported, I checked on a Windows 10 machine where it was crashing. boklm's recommendation fixes this problem. We should update the blog post or make a new release.

comment:9 Changed 3 years ago by krot

The problem still persist after I applied a workaround
Win7x64 connection via Proxy

Faulting application name: instantbird.exe, version: 41.0.0.5729, time stamp: 0x000232e8
Faulting module name: d2d1.dll, version: 6.2.9200.16765, time stamp: 0x528bf6b2
Exception code: 0xc0000005
Fault offset: 0x002284f6
Faulting process id: 0x5afc
Faulting application start time: 0x01d11322bdf6c939
Faulting application path: C:\Users\MY_user\Desktop\Tor Messenger\Messenger\instantbird.exe
Faulting module path: C:\Windows\system32\d2d1.dll
Report Id: fd19d719-7f15-11e5-869b-06450da3436b

comment:10 in reply to:  9 ; Changed 3 years ago by sukhbir

Replying to krot:

The problem still persist after I applied a workaround
Win7x64 connection via Proxy

Faulting application name: instantbird.exe, version: 41.0.0.5729, time stamp: 0x000232e8
Faulting module name: d2d1.dll, version: 6.2.9200.16765, time stamp: 0x528bf6b2
Exception code: 0xc0000005
Fault offset: 0x002284f6
Faulting process id: 0x5afc
Faulting application start time: 0x01d11322bdf6c939
Faulting application path: C:\Users\MY_user\Desktop\Tor Messenger\Messenger\instantbird.exe
Faulting module path: C:\Windows\system32\d2d1.dll
Report Id: fd19d719-7f15-11e5-869b-06450da3436b

Can you confirm whether the file is prefs.js and not prefs.js.txt? It should be prefs.js.

comment:11 in reply to:  10 ; Changed 3 years ago by krot

Replying to sukhbir:

Replying to krot:

The problem still persist after I applied a workaround
Win7x64 connection via Proxy

Faulting application name: instantbird.exe, version: 41.0.0.5729, time stamp: 0x000232e8
Faulting module name: d2d1.dll, version: 6.2.9200.16765, time stamp: 0x528bf6b2
Exception code: 0xc0000005
Fault offset: 0x002284f6
Faulting process id: 0x5afc
Faulting application start time: 0x01d11322bdf6c939
Faulting application path: C:\Users\MY_user\Desktop\Tor Messenger\Messenger\instantbird.exe
Faulting module path: C:\Windows\system32\d2d1.dll
Report Id: fd19d719-7f15-11e5-869b-06450da3436b

Can you confirm whether the file is prefs.js and not prefs.js.txt? It should be prefs.js.

Here is screenshot:http://i.imgur.com/HDg0fVq.png

comment:12 in reply to:  11 Changed 3 years ago by sukhbir

Replying to krot:

Here is screenshot:http://i.imgur.com/HDg0fVq.png

Er thanks. Sorry, just confirming what can be the issue here since I have verified independently on two machines that this should solve the issue. We will comment here if there is an update.

comment:13 Changed 3 years ago by boklm

I think I made a mistake in the file path. It should be Messenger/TorMessenger/Data/Browser/profile.default/prefs.js (not in the preferences directory). I've edited the previous comment to fix it.

Last edited 3 years ago by boklm (previous) (diff)

comment:14 in reply to:  13 ; Changed 3 years ago by sukhbir

Replying to boklm:

I think I made a mistake in the file path. It should be Messenger/TorMessenger/Data/Browser/profile.default/prefs.js (not in the preference directory).

OK that can be it. I didn't follow your path because I knew where the file should go. Let's hope this nails it down.

comment:15 in reply to:  14 ; Changed 3 years ago by krot

Replying to sukhbir:

Replying to boklm:

I think I made a mistake in the file path. It should be Messenger/TorMessenger/Data/Browser/profile.default/prefs.js (not in the preference directory).

OK that can be it. I didn't follow your path because I knew where the file should go. Let's hope this nails it down.

Yeap! Now its working! Thanx!

comment:16 in reply to:  15 Changed 3 years ago by sukhbir

Replying to krot:

Yeap! Now its working! Thanx!

Awesome! Thanks for reporting and working with us patiently on this.

comment:17 Changed 3 years ago by sukhbir

Description: modified (diff)

comment:18 Changed 3 years ago by sukhbir

Pushed.

Let's wait for a few confirmations before we close it.

comment:19 Changed 3 years ago by arlolra

Resolution: fixed
Status: newclosed

comment:20 Changed 7 weeks ago by traumschule

<+sukhe> hello. yes, I think it's fine to close the tickets. thanks for doing what we should done earlier :)

sad but true:
https://blog.torproject.org/sunsetting-tor-messenger

luckily there are alternatives:
https://blog.torproject.org/tor-heart-onion-messaging

.. and maybe someday

Note: See TracTickets for help on using tickets.