Opened 3 years ago

Closed 3 years ago

#17456 closed defect (fixed)

Reproducible crash in Network Settings on Mac

Reported by: garrettr Owned by: sukhbir
Priority: Medium Milestone:
Component: Archived/Tor Messenger Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

STR

  • Mac OS 10.10.5 Yosemite
  • Tor Messenger Beta
  1. Open Tor Messenger
  2. Click Tor Messenger, then Preferences...
  3. Click Advanced, then the Network subsection
  4. Click the Settings... button

Expected Result

The Network settings open up and the UI is responsive and configurable (even though that might not be advisable if you want to maintain your anonymity).

Actual Result

The Network settings window opens, but after a moment the cursor turns into the infamous "spinning multi-colored beach ball of doom". The application becomes unresponsive and must be Force Quit.

Child Tickets

Change History (5)

comment:1 Changed 3 years ago by sukhbir

Owner: set to sukhbir
Status: newassigned

Thanks for reporting this. This is most likely due to this patch. We will check.

comment:2 Changed 3 years ago by arlolra

sukhbir, no, I'm seeing this in Instantbird nightly as well. Will report there.

comment:3 Changed 3 years ago by arlolra

Probably a duplicate in #17540

comment:4 Changed 3 years ago by sukhbir

We should remove the patch that is causing this (osx-theme-position.patch) and put out an updated build. What do you think? The only side-effect of removing the patch is the incorrect positioning of the themes pane. I think we can live with that rather than see the entire preferences pane crash Tor Messenger.

comment:5 Changed 3 years ago by arlolra

Resolution: fixed
Status: assignedclosed

Ok, I reverted the theme position patch in 18532a17f29770bbd3f3a31a374ee781f4a7f77f and reopened #16476.

Note: See TracTickets for help on using tickets.