Opened 5 years ago

Closed 5 years ago

#17492 closed defect (fixed)

Include default bridges configuration in Tor Messenger

Reported by: boklm Owned by: boklm
Priority: Medium Milestone:
Component: Archived/Tor Messenger Version:
Severity: Normal Keywords:
Cc: arlo, sukhbir Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

In tor-browser-bundle.git/Bundle-Data/PTConfigs/bridge_prefs.js there is configuration for the default bridges. We should include that configuration in the default Tor Messenger profile.

Child Tickets

Change History (5)

comment:2 Changed 5 years ago by yawning

Ugh, I'm not sure how I feel about having yet another place we need to edit when we change the bridge list (In particular the obfs4 bridges are subject to change soon because of capacity reasons).

comment:3 in reply to:  1 Changed 5 years ago by boklm

Replying to arlolra:

I assume that https://gitweb.torproject.org/tor-messenger-build.git/commit/?id=7a1c6fd121dd001eb999ef03ebbbed264da37026 fixes #17476 as well?

Yes, this and the latest commit to use meek in standalone mode should fix #17476.

comment:4 in reply to:  2 Changed 5 years ago by boklm

Replying to yawning:

Ugh, I'm not sure how I feel about having yet another place we need to edit when we change the bridge list (In particular the obfs4 bridges are subject to change soon because of capacity reasons).

We are using the bridge_prefs.js file from tor-browser-bundle.git so there is only one place to edit. We still need to think about updating the hash of the tor-browser-bundle.git commit we use when there are bridge updates, but we can't use the latest commit automatically or this would make the build unreproducible.

comment:5 Changed 5 years ago by arlolra

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.