Opened 4 years ago

Closed 16 months ago

#17514 closed defect (duplicate)

Tor Browser installer isn't properly localized

Reported by: StrangeCharm Owned by: arthuredelstein
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: l10n
Cc: tbb-team, emmapeel Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Steps to reproduce:

  1. Navigate to https://www.torproject.org/download/download
  2. Click the Microsoft Windows tab.
  3. Select Russian or Arabic in the language dropdown.
  4. Click the DOWNLOAD Tor Browser button.
  5. Run the installer downloaded.

Expected result:

The Tor Browser installer downloaded is in the selected language, and the selected language is available in the drop-down language menu at the start of the installation process.

Actual result:

The installer is in English. Neither Arabic nor Russian are available from the language drop-down menu at the start of the installation process.

Child Tickets

Attachments (1)

ru_tbb_installer.png (7.8 KB) - added by arthuredelstein 16 months ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 17 months ago by emmapeel

Owner: changed from tbb-team to emmapeel
Status: newassigned

comment:2 Changed 17 months ago by gk

Cc: tbb-team added

comment:3 Changed 16 months ago by emmapeel

Cc: emmapeel added
Owner: changed from emmapeel to arthuredelstein

Ey arthuredelstein can you please confirm that this is fixed, and close? Cheers!

comment:4 Changed 16 months ago by arthuredelstein

Unfortunately I can confirm that this is not fixed and remains a defect in the windows installer.

Changed 16 months ago by arthuredelstein

Attachment: ru_tbb_installer.png added

comment:5 Changed 16 months ago by arthuredelstein

Here's a screenshot of torbrowser-install-7.5.6_ru.exe:


The list of locales in this drop-down seems to be the same regardless of bunlde locale, so we have the same problem for other locales, including zh and ja.

It seems, ideally, the user shouldn't have to choose a locale at this stage, as they have already chosen a locale on the download page. The installer should use automatically use the bundle's locale. Or, if we were to deploy a multi-locale download (#17400), then we should only ask for locale once (in the installer) and not twice (once in the installer and once upon startup).

comment:6 Changed 16 months ago by arthuredelstein

Summary: Tor Browser downloads do not appear translated.Tor Browser installer isn't properly localized

comment:7 Changed 16 months ago by gk

Resolution: duplicate
Status: assignedclosed

Duplicate of #11013.

Note: See TracTickets for help on using tickets.