Opened 4 years ago

Closed 3 years ago

#17526 closed defect (duplicate)

Riseup hidden service failing on Tor Messenger

Reported by: alison Owned by:
Priority: Medium Milestone:
Component: Archived/Tor Messenger Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I'm getting a connection failure for Riseup's Jabber hidden service. Attempting to connection to 4cjw6cwpeaeppfqz.onion gives a cert error, and then it won't allow me to add an exception for that hs in preferences. Regular xmpp.riseup.net works fine. Please see attached screenshots.

Child Tickets

Attachments (2)

Screen Shot 2015-11-03 at 6.17.57 PM.png (24.3 KB) - added by alison 4 years ago.
Screen Shot 2015-11-03 at 6.17.19 PM.png (54.3 KB) - added by alison 4 years ago.

Download all attachments as: .zip

Change History (7)

Changed 4 years ago by alison

Changed 4 years ago by alison

comment:1 Changed 4 years ago by arlolra

From the second screenshot, it looks like you don't have the port set.

The location in that window should say, 4cjw6cwpeaeppfqz.onion:5222

Open the account window and click on properties for that account.

In advanced options, the server should be 4cjw6cwpeaeppfqz.onion and port 5222.

Hope that helps.

comment:2 Changed 4 years ago by arma

If Arlo's guess does turn out to be right, somebody should open a usability ticket here. :)

comment:3 Changed 4 years ago by arlolra

The default port there is 5222, so I'm curious to how it's gone missing.

We already have a usability ticket for this, it's #13855, but see the discussion there for why that patch got backed out and convince us differently.

comment:4 Changed 4 years ago by sukhbir

I tried connecting without setting the port explicitly (5222 is the default port in any case) and it worked. But ilv reported he couldn't connect also and I haven't been able to reproduce that.

Alison, if you notice closely, above the "Connect" button, there should be an option to "Add Exception" but it's almost impossible to see because it's a blue on blue. ilv reported this in #17517. We need to change the colour.

comment:5 Changed 3 years ago by arlolra

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.