#17552 closed defect (fixed)

OTR interoperability with Psi+ does not work

Reported by: niemalsnever Owned by:
Priority: Medium Milestone:
Component: Applications/Tor Messenger Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When one party in a conversation is using Tor Messenger and the other is using Psi+, no OTR-session can be established. This fails in both directions.

Steps to reproduce:

  • Start Tor Messenger and initiate a conversation with a Psi+ user
  • Start an OTR-session from either end.

Expected outcome:

  • Tor Messenger will establish an OTR-session with the party using Psi+ on the other end.

Actual outcome:

  • No OTR-session will be established.

Child Tickets

Change History (7)

comment:1 Changed 18 months ago by arlolra

Can you confirm that Psi+ is able to establish an OTR session with any other client? I'm not familiar with it.

Are any errors generated?

comment:2 Changed 18 months ago by niemalsnever

Psi+ is able to establish OTR-sessions with at least Pidgin/Adium/libpurple, Xabber for Android and of course itself.

Unfortunately there are no errors generated, at least none visible to the normal user. Regrettably I've only just noticed the Error Console in Tor Messenger, and all of my Psi+ contacts are already offline so I can't check whether there are any errors thrown to the Error Console just now, but I will try testing it further as soon as possible.

comment:3 follow-up: Changed 18 months ago by arlolra

Interesting, because Tor Messenger uses the same OTR library as Pidgin/Adium. Perhaps it's a policy issue? I'll try downloading Psi+ and its OTR plugin.

Thanks for reporting.

comment:4 in reply to: ↑ 3 Changed 18 months ago by niemalsnever

Replying to arlolra:

Interesting, because Tor Messenger uses the same OTR library as Pidgin/Adium. Perhaps it's a policy issue? I'll try downloading Psi+ and its OTR plugin.

Thanks for reporting.

Here, this is the link to the Psi+ OTR-Plugin: https://github.com/psi-plus/plugins/tree/master/generic/otrplugin

Maybe Psi+'s version of the OTR library is too old and Tor Messenger considers it insecure. (Last commit 2 years ago)

comment:5 Changed 18 months ago by arlolra

Aha!

So the message stanzas that the Psi+ OTR plugin emits include a <subject> like,

<subject xmlns="jabber:client"/>

which the Instantbird xmpp implementation seems to be barfing on,

Error: muc is undefined
Source File: resource:///modules/xmpp.jsm

Since it's throwing, those message aren't properly received on our end.

Working on a fix. Thanks for reporting and using beta software :)

comment:6 Changed 18 months ago by arlolra

comment:7 Changed 18 months ago by arlolra

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.