Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#17575 closed defect (worksforme)

Openstreetmap GUI elements not rendered

Reported by: quazgar Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Minor Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

With the current stable Tor Browser (5.0.4), some elements of openstreetmap are not rendered correctly, see the attached screenshot.

The missing elements include:

  • "x" to close GUI elements
  • Icons for layer selection etc.

Note that this also happens with the NoScript plugin disabled, and it does not happen in a plain Firefox with NoScript (osm whitelisted though, of course).

PS: I see that the Tor bug tracker formatting buttons also seem to be affected.

Child Tickets

Attachments (1)

osm.png (264.8 KB) - added by quazgar 4 years ago.
Screenshot showing the problem.

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by quazgar

Attachment: osm.png added

Screenshot showing the problem.

comment:1 Changed 4 years ago by gk

Resolution: worksforme
Status: newclosed

This works pretty well for me on a 64bit Linux machine both with a vanilla 5.0.4 and 5.5a4. Only setting the security slider to level high shows your issues but that is kind of expected. Feel free to reopen this bug if there is more to it.

comment:2 Changed 4 years ago by quazgar

Ok, works for the second highest setting.

I assume that the easiest way to "fix" this for selected/whitelisted sites would be to have a patch added to NoScript which includes blocking (and thereby also unblocking) of SVG elements. Then this setting be removed from the Tor browser and be enabled/disbaled on a per-site base.

Note: See TracTickets for help on using tickets.