Opened 4 years ago

Closed 4 years ago

#17602 closed defect (not a bug)

'HidServDirectoryV2 0' not disabling HSDir

Reported by: seeess Owned by:
Priority: Very Low Milestone: Tor: 0.2.8.x-final
Component: Core Tor/Tor Version: Tor: 0.2.7.4-rc
Severity: Minor Keywords: easy docs
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

torrc:

DirPort 9
ORPort 443
#ControlPort 9051
#CookieAuthentication 1
Exitpolicy reject *:*
Nickname xxx
ContactInfo xxx
SocksPort 0
#BridgeRelay 1
#ServerTransportPlugin obfs3 exec /usr/local/bin/obfsproxy managed
#ExtORPort auto
User debian
DataDirectory /usr/local/etc/tor

BandwidthRate 6MBytes
BandwidthBurst 10MBytes
AvoidDiskWrites 1
#TunnelDirConns 1
#PreferTunneledDirConns 1
EntryStatistics 1
ConnDirectionStatistics 1

HidServDirectoryV2 0
HiddenServiceStatistics 1
#DisableDebuggerAttachment 0 #needed for arm stats
Log notice stdout
Log [rend,net,config,dir]info

Both atlas and globe show my relay having the "HSDir" flag, this torrc configuration was last changed on oct 25, and the tor process (and whole computer) was restarted since then.

I probably shouldn't be setting "HiddenServiceStatistics 1" anymore, but shouldn't HidServDirectoryV2 0 supersede HiddenServiceStatistics?
Is the relay being a v1 hidden service directory? I thought v1 was only for auth dirs?

Child Tickets

Change History (4)

comment:1 Changed 4 years ago by nickm

Milestone: Tor: 0.2.8.x-final
Priority: LowHigh

comment:2 Changed 4 years ago by teor

Priority: HighVery Low
Severity: NormalMinor

There is currently no way to disable the HSDir flag on a relay using that relay's torrc file.

In the current master branch:

  • HidServDirectoryV2 is declared in config.c as OBSOLETE("HidServDirectoryV2"),.
  • HidServDirectoryV2 is not used anywhere else in the code.
  • The man page paragraph for HidServDirectoryV2 is out of date, and still describes the option as if it is effective. (That paragraph should be deleted.)

Given that HidServDirectoryV2 is an obsolete option, we can't have it override HiddenServiceStatistics.

To fix the issue that was reported:
Please set HiddenServiceStatistics 0 to disable HiddenServiceStatistics.

To fix the documentation issue:
Delete the paragraph for HidServDirectoryV2 from the tor manual page.

comment:3 Changed 4 years ago by teor

Keywords: easy docs added

comment:4 Changed 4 years ago by nickm

Resolution: not a bug
Status: newclosed

HidServDirectoryV2 has been deleted from the manpage a while ago.

Note: See TracTickets for help on using tickets.