Opened 4 years ago

Closed 4 years ago

#17651 closed defect (worksforme)

Torbrowser crash

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-crash
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

www.nytimes.com/interactive/2015/11/21/world/middleeast/inside-raqqa-capital-of-isis.html

Clicking through the slides of this link is causing the torbrowser to crash/exit.

Privacy settings Low. Browser version 5.0.4. OS Debian 7.9.

Child Tickets

Change History (8)

comment:1 Changed 4 years ago by cypherpunks

out of memory: 0x0000000000000070 bytes requested

It's OOM case, not a bug for Firefox-type browser in general, test of vanilla ESR required yet.

It's unsafe to visit those link if your linux (with broken memory manager by design) can't to reload evicted pages reliably (FDE, Tails, etc), it will freeze your OS entirely.

comment:2 Changed 4 years ago by cypherpunks

Btw, this bug seems like is about svg, again. Not this one I hope.

comment:3 Changed 4 years ago by gk

Keywords: tbb-crash added

comment:4 Changed 4 years ago by teor

I can't replicate this on OS X with Tor Browser 5.0.4 (Low and Medium-Low), but I can confirm that the site downloads multiple megabytes of image files.

The slideshow is somewhat glitchy: one of the image files failed to download completely, and the blurred part of that image is now cached and appearing repeatedly in the slideshow.

comment:5 Changed 4 years ago by cypherpunks

I'm OP. I should have mentioned that the crash happened with the 32bit version of tor browser. I don't know if the 64bit version is affected.

comment:6 Changed 4 years ago by mcs

I was unable to reproduce this problem on an old Fedora 32-bit system. I tested with a newly installed copy of TB 5.0.4. Like teor, I saw a couple of glitches in the slideshow, but it seemed to work OK overall. I did not analyze the slideshow in detail, but it uses a combination of PNG, JPG, and SVG images.

comment:7 Changed 4 years ago by cypherpunks

They changed something, now browser using at worst case ~2GB only.

comment:8 Changed 4 years ago by cypherpunks

Resolution: worksforme
Status: newclosed

OP here. I just tried it again and this time it did not crash, I think the nytimes did fix something on their side. Closing the ticket for now.

Note: See TracTickets for help on using tickets.