Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#17691 closed defect (not a bug)

Arm won't work

Reported by: Woodstock Owned by: atagar
Priority: Medium Milestone:
Component: Core Tor/Nyx Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hello, i tried to install Arm today and got the following error when i double klick arm. i also get a failed when i klick on the installer. Im using mac OS X El Capitan in Public Beta and the Tor bundle from the official Site. i have no firewall enabled and Tor is running. I hope you can help me. I added two pictures with the error.

Child Tickets

Attachments (2)

arm2.tiff (205.7 KB) - added by Woodstock 3 years ago.
arm.jpg (756.9 KB) - added by Woodstock 3 years ago.

Download all attachments as: .zip

Change History (8)

Changed 3 years ago by Woodstock

Attachment: arm2.tiff added

Changed 3 years ago by Woodstock

Attachment: arm.jpg added

comment:1 Changed 3 years ago by atagar

Component: - Select a componentNyx
Owner: set to atagar

comment:2 Changed 3 years ago by atagar

Resolution: not a bug
Status: newclosed

Hi Woodstock, the notice you're getting says "Connection refused. Is the ControlPort enabled?". If you check the readme there's more to running arm than simply invoking it - you need to configure tor too.

comment:3 Changed 3 years ago by Woodstock

Hello Atagar, thank you for the info. i read the file now and added the controlport 9151 to the torrc file. if i understand it right, arm will take the infos from the tor configuration when i set all right and create the armrc in the .arm folder? Oh and Python 2.7.10 is installed, do you know why the errno 2 appears when i hit the install file? Thank you Atgar

comment:4 Changed 3 years ago by atagar

Hi Woodstock.

read the file now and added the controlport 9151 to the torrc file.

Don't forget to restart tor after you've changed the torrc. Since you chose 9151 you should hopefully then be able to start arm by running...

arm --interface 9151

if i understand it right, arm will take the infos from the tor configuration when i set all right and create the armrc in the .arm folder?

Nope, changing the torrc doesn't have anything to do with the armrc. You're simply telling tor to allow controller connections on port 9151 which will allow arm to connect. Don't worry about the armrc (that's just for customizing arm if you want).

Oh and Python 2.7.10 is installed, do you know why the errno 2 appears when i hit the install file?

Python 2.7 is fine. I don't know what error you're talking about.

comment:5 Changed 3 years ago by Woodstock

can you tell me which port is better to use instead of 9151? i tried 9050 before but Tor won't start with this one. 
Ok great, the armrc is my next step when i get the controller connection to work.

Thanks for helping, i will try it out later, have to sleep a bit.

comment:6 Changed 3 years ago by atagar

9051 is the default port, so if you use that you shouldn't need the '--interface' argument.

Note: See TracTickets for help on using tickets.