Opened 4 years ago

Last modified 21 months ago

#17718 reopened defect

About:config values need changing

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-pref
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

github.com/pyllyukko/user.js/blob/master/user.js

has a lot of privacy settings that can be disabled. although torbutton+tbb uses some of the right settings, i'm sure there are a few you have missed such as:

camera.control.face_detection.enabled
webgl.disabled
beacon.enabled

etc.

Child Tickets

Change History (4)

comment:1 Changed 4 years ago by gk

Resolution: not a bug
Status: newclosed

I think those three are fine. Have a look at our design document to see what we are doing + why and how: https://www.torproject.org/projects/torbrowser/design/

comment:2 Changed 4 years ago by cypherpunks

Resolution: not a bug
Status: closedreopened

Those 3 mentioned are just few of many more.

I do remember 1-2 years ago seeing disk avoidance in the TBB design but the config value for cache was to write to disk instead of store in memory (whether this was somehow already done in a deeper level I don't know).

Have any developers looked at all the config values? I really think it is useful and some may have been missed. If developers have already looked at all of it, then feel free to close this.

comment:3 Changed 3 years ago by bugzilla

Keywords: tbb-pref added

https://github.com/pyllyukko/user.js/blob/master/user.js
is a really good source for thinking about revising pref policy.
Particularly, user_pref("privacy.clearOnShutdown.siteSettings", false); raises questions...

#18971 is a duplicate.

comment:4 Changed 21 months ago by cypherpunks

From Bug #23879 - another good source of about:config prefs we are missing: ​https://github.com/The-OP/Fox

Note: See TracTickets for help on using tickets.