Opened 4 years ago

Closed 4 years ago

#17723 closed defect (not a bug)

connection_tls_continue_handshake: Assertion !tor_tls_is_server(conn->tls) failed

Reported by: virii Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: unspecified
Severity: Normal Keywords: TLS handshake
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Tor is running on a debian machine, 64bit. (Debian 3.2.65-1+deb7u2).
The Tor daemon terminates under Tor v0.2.8.0-alpha-dev with the following Output:

Nov 25 21:50:36.000 [err] tor_assertion_failed_(): Bug: ../src/or/connection_or.c:1483: connection_tls_continue_handshake: Assertion !tor_tls_is_server(conn->tls) failed; aborting. (on Tor 0.2.8.0-alpha-dev )
Nov 25 21:50:36.000 [err] Bug: Assertion !tor_tls_is_server(conn->tls) failed in connection_tls_continue_handshake at ../src/or/connection_or.c:1483. Stack trace: (on Tor 0.2.8.0-alpha-dev )
Nov 25 21:50:36.000 [err] Bug: /usr/bin/tor(log_backtrace+0x42) [0x7fe0978887a2] (on Tor 0.2.8.0-alpha-dev )
Nov 25 21:50:36.000 [err] Bug: /usr/bin/tor(tor_assertion_failed_+0x8c) [0x7fe097896a0c] (on Tor 0.2.8.0-alpha-dev )
Nov 25 21:50:36.000 [err] Bug: /usr/bin/tor(connection_tls_continue_handshake+0x2a3) [0x7fe097848413] (on Tor 0.2.8.0-alpha-dev )
Nov 25 21:50:36.000 [err] Bug: /usr/bin/tor(+0xe5243) [0x7fe09783d243] (on Tor 0.2.8.0-alpha-dev )
Nov 25 21:50:36.000 [err] Bug: /usr/bin/tor(+0x3ecd1) [0x7fe097796cd1] (on Tor 0.2.8.0-alpha-dev )
Nov 25 21:50:36.000 [err] Bug: /usr/lib/x86_64-linux-gnu/libevent-2.0.so.5(event_base_loop+0x7fc) [0x7fe096de13dc] (on Tor 0.2.8.0-alpha-dev )
Nov 25 21:50:36.000 [err] Bug: /usr/bin/tor(do_main_loop+0x274) [0x7fe097797c84] (on Tor 0.2.8.0-alpha-dev )
Nov 25 21:50:36.000 [err] Bug: /usr/bin/tor(tor_main+0x19ad) [0x7fe09779b1fd] (on Tor 0.2.8.0-alpha-dev )
Nov 25 21:50:36.000 [err] Bug: /usr/bin/tor(main+0x19) [0x7fe097793949] (on Tor 0.2.8.0-alpha-dev )
Nov 25 21:50:36.000 [err] Bug: /lib/x86_64-linux-gnu/libc.so.6(libc_start_main+0xf5) [0x7fe095b92b45] (on Tor 0.2.8.0-alpha-dev)
Nov 25 21:50:36.000 [err] Bug: /usr/bin/tor(+0x3b999) [0x7fe097793999] (on Tor 0.2.8.0-alpha-dev )

This error shows up after some time. 30 minutes - 1 hour.

Child Tickets

Change History (2)

comment:1 Changed 4 years ago by cypherpunks

This looks like a duplicate of #17654.

comment:2 Changed 4 years ago by dgoulet

Resolution: not a bug
Status: newclosed

It has been fixed in git master (but not yet released as a version). If you are still experiencing this after upgrading to git master, re-open #17654. Thanks.

Note: See TracTickets for help on using tickets.