Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#17725 closed enhancement (not a bug)

Tor Strictnodes / Exitnodes doesn't work anymore.

Reported by: dscale Owned by:
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I have set up the torcc file with

StrictNodes 1
ExitNodes {us}

And it is not working, as it did on previous versions of TOR. Please help?

It seems it works only on 50% of the circuits only..

Child Tickets

Change History (9)

comment:1 Changed 4 years ago by teor

Component: - Select a componentTor
Milestone: Tor: 0.2.8.x-final
Severity: NormalMajor
Status: newneeds_information

Can you please tell us which version of Tor you are using?
Are you using it as a client?

comment:2 Changed 4 years ago by dscale

Tor Browser 5.0.4
I am using the browser. Not sure what you mean by client.
StrictNodes worked properly on versions before this one. Now its random if it wants to listen to StrictNodes or not.

I checked this thread: http://stackoverflow.com/questions/13422099/tor-strictexitnodes-is-not-working
I tried to run from command prompt using -f and direct to the torrc file but it doesn't work. It just tries to load that file in the browser.

Last edited 4 years ago by dscale (previous) (diff)

comment:3 Changed 4 years ago by teor

Priority: HighVery High
Severity: MajorCritical
Version: Tor: 0.2.6.10

What was the last version of Tor Browser that worked for you?

Where is the torrc file that you are editing?

Note for developers: the version of tor distributed with Tor Browser 5.0.4 is:
Tor version 0.2.6.10 (git-cab52fe998909e08).

comment:4 Changed 4 years ago by dscale

C:\Users\Comp\Desktop\Tor Browser\Browser\TorBrowser\Data\Tor\torrc

The previous version I was using was the one right before this one.
It is very strange if I change the countrycode, it will load up properly for google. But then if I go to any other site it will just change the circuit and start ignoring StrictNodes afterwards.

Last edited 4 years ago by dscale (previous) (diff)

comment:5 Changed 4 years ago by teor

When I use Tor Browser 5.0.4 on OS X with:

StrictNodes 1
ExitNodes {us}

When I click on the Onion button in the toolbar, and then look at "Tor circuit for this site", I always see the last relay before "Internet" in "United States". (I tested this on 10 different sites.)

Since I can't replicate what you're seeing on my machine, I need more specific information.

If you are able, can you please attach to this ticket:

  • your entire torrc file
  • a screenshot of the "Tor circuit for this site" when the Onion button is pressed
  • any other information that shows that StrictNodes / ExitNodes is not working for you

comment:6 Changed 4 years ago by dscale

It is exactly as you have it, only those two lines in the torrc file. Are you checking Onion sites? It seems to work perfectly fine on regular sites. But on Onions sites it never works. Is that how it is supposed to be?

Last edited 4 years ago by dscale (previous) (diff)

comment:7 Changed 4 years ago by gk

What do you mean with "earlier version of TOR"? We did not change the Tor version in 5.0.4. It is the same as in Tor Browser 5.0.3. Or do you mean earlier version of Tor Browser? If so, which version is the last one that is working for you?

comment:8 in reply to:  6 Changed 4 years ago by teor

Component: TorTor Browser
Milestone: Tor: 0.2.8.x-final
Priority: Very HighMedium
Severity: CriticalNormal
Type: defectenhancement
Version: Tor: 0.2.6.10

Replying to dscale:

It is exactly as you have it, only those two lines in the torrc file. Are you checking Onion sites? It seems to work perfectly fine on regular sites. But on Onions sites it never works. Is that how it is supposed to be?

Yes, dscale, that is how onion sites are supposed to work.

The third relay in your path to an onion site is not an exit. All of your traffic to an onion site stays within the Tor network.

Onion sites have always worked this way, but Tor Browser has only recently started showing the paths to onion sites.

gk, I 'm not sure if there is anything we can do to make this clearer in TorButton, Tor Browser, or in the documentation. Do you have any ideas?

comment:9 Changed 4 years ago by gk

Resolution: not a bug
Status: needs_informationclosed

I think the Tor manpage/Tor manual on our website are quite explicit on how this is working.

Last edited 4 years ago by gk (previous) (diff)
Note: See TracTickets for help on using tickets.