Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#17733 closed defect (duplicate)

Adjust windows size on adding of bookmarks toolbar

Reported by: twim Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-fingerprinting-resolution
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Window adjusting is a bit delayed that can aid in session fingerprinting.
Reproducable that way:

  1. 1000x700x24 - vanilla TB window
  2. 1000x668x24 - w/ bookmarks bar, right after adding
  3. 1000x700x24 - w/ bookmarks bar, after restart/new identity

I propose to adjust window size at (2) to be in the same state as at (3).
It's better than dropping a warning but a warning can be a solution for the first time.

Child Tickets

Change History (1)

comment:1 Changed 4 years ago by bugzilla

Keywords: tbb-fingerprinting-resolution added; tor-browser window size fingerprinting removed
Resolution: duplicate
Status: newclosed

Closed as a duplicate of #16456.

Last edited 4 years ago by bugzilla (previous) (diff)
Note: See TracTickets for help on using tickets.