Opened 3 years ago

Closed 3 years ago

#17760 closed defect (duplicate)

Torsocks doesn't quote variables, will choke on spaces and special characters in paths

Reported by: teor Owned by: dgoulet
Priority: Medium Milestone:
Component: Core Tor/Torsocks Version:
Severity: Normal Keywords: easy
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The script that launches a command using torsocks checks a lot of paths without quoting them.

This means that paths with spaces will cause errors, and paths with special characters may have unintended effects.

Child Tickets

Change History (1)

comment:1 Changed 3 years ago by cypherpunks

Resolution: duplicate
Status: newclosed

Closing as duplicate of #19376 which has a patch.

Note: See TracTickets for help on using tickets.