Opened 4 years ago

Closed 4 years ago

#17829 closed defect (wontfix)

Spoof plugin list

Reported by: hakim Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Major Keywords: fingerprint, plugins
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Add spoof plugin list and preferences

Preferences

plugin.spoof.enable: bool
plugin.spoof.list: str (see example)

For example:


       "mimeTypes": [
         "description": "Random",
         "suffixes": "random",
         "type": "application/random"
      ],
      "plugins": [
         "application/random": {},
         "description": "Random BLah",
         "filename": "shaurma.dll",
         "version": "454654.077",
         "name": "Random",
         "length": 1
      ]

Child Tickets

Change History (3)

comment:1 Changed 4 years ago by gk

Status: newneeds_information

Why do you think we need this, given that we don't ship plugins in Tor Browser and MIME types are not enumerable (more)?

comment:2 in reply to:  1 ; Changed 4 years ago by hakim

Replying to gk:

Why do you think we need this, given that we don't ship plugins in Tor Browser and MIME types are not enumerable (more)?

currently Tor Browser have static fingerprint, it will make randomly fingerprint

comment:3 in reply to:  2 Changed 4 years ago by gk

Resolution: wontfix
Status: needs_informationclosed

Replying to hakim:

Replying to gk:

Why do you think we need this, given that we don't ship plugins in Tor Browser and MIME types are not enumerable (more)?

currently Tor Browser have static fingerprint, it will make randomly fingerprint

That is actually a feature, not a bug. Have a look at subsection "Strategies for Defense: Randomization versus Uniformity" in our design documentation: https://www.torproject.org/projects/torbrowser/design/#fingerprinting-linkability

Note: See TracTickets for help on using tickets.