Opened 2 years ago

Closed 20 months ago

#17836 closed defect (wontfix)

Can't complete Twitter authorization process

Reported by: bernie.allen Owned by: sukhbir
Priority: Medium Milestone:
Component: Applications/TorBirdy Version:
Severity: Normal Keywords: twitter
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

  1. Connect to Twitter account for first time. => "Give permission to use your Twitter account" window appears.
  2. Enter password. Press "Authorize app".
  3. A new page loads, "Log in to Twitter", with another login form. (Trying to log in again just repeats this step.)

Maybe this problem is outside the scope of TorBirdy. I confirmed I can log in to Twitter using Tor Browser with the same username and password.

I've been using TorBirdy with this same account on another machine for over a year without issue.

TorBirdy 0.1.4, Icedove 31.8.0

Child Tickets

Change History (2)

comment:1 Changed 22 months ago by jinankjain

I would like to work on this bug, is it still open?

comment:2 Changed 20 months ago by sukhbir

Resolution: wontfix
Status: newclosed

This is probably because we are setting this pref in TorBirdy (in components/torbirdy.js):

  // No cookies are allowed.
  "network.cookie.cookieBehavior": 2,

On one hand, I guess we can support Twitter even though it is not directly related to TorBirdy but on the other, if you want to use Twitter or XMPP safely, there is Tor Messenger does a bunch of other stuff as well and is more safer.

I am going to mark this as closed because now you know the issue, and it's unlikely that we plan to support chat functionality with TorBirdy.

Note: See TracTickets for help on using tickets.