Opened 4 years ago

Closed 4 years ago

#17838 closed defect (duplicate)

0.2.7.6 not building on OpenBSD 5.8 (Makefile parse errors)

Reported by: chooCoh1 Owned by:
Priority: Medium Milestone: Tor: 0.2.7.x-final
Component: Core Tor/Tor Version: Tor: 0.2.7.6
Severity: Normal Keywords: OpenBSD regression
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Current version 0.2.7.6 is not building on OpenBSD 5.8, due to the following error when running "make" (procedure: ./configure && make).

* Parse error in /home/user/tor-0.2.7.6: Need an operator in 'TESTING_TOR_BINARY=./src/or/tor' (Makefile:6772)
* Parse error: Need an operator in 'PYTHON=' (Makefile:6794)
* Parse error: Need an operator in 'SHELL=/bin/sh' (Makefile:6795)
* Parse error: Need an operator in 'abs_top_srcdir=/home/user/tor-0.2.7.6' (Makefile:6796)
* Parse error: Need an operator in 'builddir=.' (Makefile:6797)

Child Tickets

Change History (6)

comment:1 Changed 4 years ago by teor

Status: newneeds_information

Have you tried gmake? (GNU make)
Does your make have a GNU make or any other compatibility modes?

I tested the 0.2.7.6 release on FreeBSD 10.1-p19 before release. Everything built and unit tested ok, except for a minor issue with the backtrace test logged as #17808.

How does your make differ from the one distributed with FreeBSD 10.1-p19?

comment:2 Changed 4 years ago by teor

Keywords: regression added
Milestone: Tor: 0.2.7.x-final

Also, what was the last release that successfully built on your OpenBSD 5.8?

comment:3 Changed 4 years ago by chooCoh1

tor-0.2.6.7 was the last version I tried and it built successfully with the make shipped in OpenBSD. I don't know how the FreeBSD and OpenBSD make differ.

I have now tried gmake and it works. If gmake is a build dependency now it probably should be noted in the build instructions.

comment:4 Changed 4 years ago by cypherpunks

I think this is a duplicate of #17818.

comment:5 Changed 4 years ago by teor

chooCoh1, do the patches in #17818 work for you?

comment:6 Changed 4 years ago by nickm

Resolution: duplicate
Status: needs_informationclosed

Closing as duplicate of #17818

Note: See TracTickets for help on using tickets.