Opened 3 years ago

Closed 3 years ago

#17850 closed enhancement (duplicate)

other relays can confuse NATed relays

Reported by: herzi Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

This is from /var/log/tor/log:

Dec 13 02:21:00.000 [notice] Our IP Address has changed from 91.45.222.226 to 104.233.75.228; rebuilding descriptor (source: 104.233.75.165).
Dec 13 02:21:12.000 [notice] We'd like to launch a circuit to handle a connection, but we already have 32 general-purpose client circuits pending. Waiting until some finish. [701 similar message(s) suppressed in last 600 seconds]
Dec 13 02:21:35.000 [notice] Our IP Address has changed from 104.233.75.228 to 91.45.222.226; rebuilding descriptor (source: 217.79.179.177).

It looks like .228 is confused causes my relay to advertise the wrong IP address for several seconds.

Maybe a NATed OR should self-test its reachability before advertising the new IP address.

Child Tickets

Change History (1)

comment:1 Changed 3 years ago by teor

Resolution: duplicate
Status: newclosed

This is a duplicate of #17782, moved the suggestion to there:
"Maybe a NATed OR should self-test its reachability before advertising the new IP address."

Note: See TracTickets for help on using tickets.