Opened 3 years ago

Last modified 15 months ago

#17879 reopened defect

Activating the Flash Player is not working anymore since Tor Browser 5.0.5

Reported by: gk Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Major Keywords: tbb-usability-website, TorBrowserTeam201512
Cc: arthuredelstein Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

There are a bunch of users that are complaining about the Flash Player not working anymore e.g. on sites like www.pandora.com. What is going on, I think, is the *detection* being broken which is very likely due to the fix for #17207. The Flash Player itself is still working for me, e.g. on Adobe's test site.

It's unfortunate that this did not get caught in our alpha series but here we are. I guess providing a preference allowing to disable the fix for #17207 might be worth it given that a number of users wouldn't be using Tor Browser otherwise or would be trying to shoot themselves in the foot with having different browsers opened simultaneously.

Child Tickets

Change History (8)

comment:1 Changed 3 years ago by gk

Resolution: not a bug
Status: newclosed

Alright, re-reading the code and doing a bit more testing reveals that we already bind this to the fingerprinting preference, good! Sorry for the noise.

comment:2 Changed 2 years ago by bugzilla

Resolution: not a bug
Status: closedreopened

Stop using Mozilla's broken "Ask to Activate". Use NoScript (4 checkboxes) instead.
https://bugzilla.mozilla.org/show_bug.cgi?id=1186948

comment:3 Changed 2 years ago by gk

Resolution: fixed
Status: reopenedclosed

Maybe file a different bug (although the description of your issue could be a bit more specific then)?

comment:4 Changed 2 years ago by bugzilla

*detection* being broken which is very likely due to the fix for #17207.

Yes, and if you reread that mozbug carefully, you'll find out why you should add Flash to an exception. (In short: https://www.fxsitecompat.com/en-CA/docs/2016/navigator-plugins-and-navigator-mimetypes-no-longer-list-flash-when-it-s-click-to-activate)

The Flash Player itself is still working for me, e.g. on Adobe's test site.

https://helpx.adobe.com/flash-player.html
Where does it work for you???

Maybe file a different bug (although the description of your issue could be a bit more specific then)?

You preferred to remove Flash from https://wiki.mozilla.org/Plugins/Firefox_Whitelist without testing instead of using NoScript for better CTP functionality, so your description in this ticket is specific enough for your issue.

comment:5 in reply to:  4 ; Changed 2 years ago by gk

Replying to bugzilla:

*detection* being broken which is very likely due to the fix for #17207.

Yes, and if you reread that mozbug carefully, you'll find out why you should add Flash to an exception. (In short: https://www.fxsitecompat.com/en-CA/docs/2016/navigator-plugins-and-navigator-mimetypes-no-longer-list-flash-when-it-s-click-to-activate)

I have a hard time following you. First: The bug you are alluding to landed in Firefox 50 and this is unrelated to anything we ship in ESR45. Second and more important: that change is not even active due to issues Mozilla found. See the updates on the site you linked to and https://bugzilla.mozilla.org/show_bug.cgi?id=1296004.

comment:6 in reply to:  5 Changed 2 years ago by bugzilla

Replying to gk:

Replying to bugzilla:

*detection* being broken which is very likely due to the fix for #17207.

Yes, and if you reread that mozbug carefully, you'll find out why you should add Flash to an exception. (In short: https://www.fxsitecompat.com/en-CA/docs/2016/navigator-plugins-and-navigator-mimetypes-no-longer-list-flash-when-it-s-click-to-activate)

I have a hard time following you. First: The bug you are alluding to landed in Firefox 50 and this is unrelated to anything we ship in ESR45. Second and more important: that change is not even active due to issues Mozilla found. See the updates on the site you linked to and https://bugzilla.mozilla.org/show_bug.cgi?id=1296004.

You have already changed plugin.state.flash the way Mozilla is trying to change in FF50, but still unsuccessful, because of the reasons which also affect TBB.

comment:7 Changed 2 years ago by bugzilla

Resolution: fixed
Status: closedreopened

What else is needed to be written in order to make you realize that you are

using Mozilla's broken "Ask to Activate".

since #9867?
(https://www.fxsitecompat.com/en-CA/docs/2016/all-plug-ins-other-than-flash-are-now-defaulted-to-click-to-activate/)

Last edited 2 years ago by bugzilla (previous) (diff)

comment:8 Changed 15 months ago by cypherpunks

Flash plugin Click-to-Play (aka "Ask to Activate") is finally fixed in upstream https://bugzilla.mozilla.org/show_bug.cgi?id=1365714

Note: See TracTickets for help on using tickets.