Opened 3 years ago

Closed 13 months ago

#17883 closed defect (worksforme)

Tor crashes on New York Times website

Reported by: mwolfe Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-crash, tbb-oom
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I opened the New York Times website today, right after installing Tor Browser 5.0.5, and it crashed with a 'Program stopped working' error message.

First, I opened 3 tabs and it crashed. So I went to the New York Times site to copy the 3 links so I could include them without opening them, and it crashed after the New York Times site had been open for about 1 minute (I had just copied one link, but had not opened it).

I am running Windows 7 Professional Service Pack 1.

I don't know if there is a Windows dump somewhere with more information. And I don't know much more. I had been browsing other websites with no problem, but the New York Times site crashed Tor 3 times in about 6 minutes, so I'm not going to try to open it again from Windows. I have Privacy set to Medium Low.

Child Tickets

Attachments (1)

torbrowsercrashlog.txt (1.7 KB) - added by mwolfe 3 years ago.
crash log?

Download all attachments as: .zip

Change History (8)

comment:1 Changed 3 years ago by mwolfe

I accessed the New York Times site with Privacy set to high, and it does not crash. However, most of the features I use are disabled.

comment:2 Changed 3 years ago by mwolfe

I set Privacy to high, opened the New York Times (www.nytimes.com) and then opened three tabs.

I closed the home page, set privacy to Medium Low, and was able to read Cohen's column (www.nytimes.com/2015/12/18/opinion/the-assassination-in-israel-that-worked.html). I refreshed the page and was able to read the comments. I have two more tabs open, but not refreshed, so the restrictions of Privacy High still apply:

www.nytimes.com/2015/12/17/opinion/campaign-stops/the-gop-at-a-crossroads.html

markets.on.nytimes.com/research/markets/commodities/commodities.asp

comment:3 Changed 3 years ago by mwolfe

I refreshed all the three tabs with Privacy Medium Low and all worked perfectly.

It was the home page, www.nytimes.com that caused the crash.

Changed 3 years ago by mwolfe

Attachment: torbrowsercrashlog.txt added

crash log?

comment:4 Changed 3 years ago by cypherpunks

Exception code: 0xc0000005
Fault offset: 0x00041416

Located at code implemented by MOZ_REALLY_CRASH macro, line number for reported case is 0x26E (622). Probably involved by NS_ABORT_OOM or something. NYT was mentioned by #17651, where it was about OOM crash too.

You need at least 3GB of VM for browser to surf NYT peacefully, it seems. OOM crash is not a bug in the Firefox universe.

comment:5 Changed 3 years ago by cypherpunks

Keywords: tbb-crash added
Version: Tor: unspecified

comment:6 Changed 3 years ago by cypherpunks

Keywords: OOM added

comment:7 Changed 13 months ago by cypherpunks

Keywords: tbb-oom added; OOM removed
Resolution: worksforme
Status: newclosed

E10S made triggering such issues much harder.

Note: See TracTickets for help on using tickets.