Opened 3 years ago

Closed 3 years ago

#17889 closed enhancement (duplicate)

Make ClientPreferIPv6ORPort apply to bridge clients

Reported by: teor Owned by:
Priority: Medium Milestone: Tor: 0.2.8.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: ipv6 bridges
Cc: Actual Points:
Parent ID: #17811 Points:
Reviewer: Sponsor:

Description

After #17840, clients that don't use bridges will select ORPorts using ClientPreferIPv6ORPort.

We could do this for bridges as well, by modifying the new function fascist_firewall_choose_address_base:

  • use ClientPreferIPv6ORPort to choose a preferred address for bridge clients,
  • but ignore the "preferred address only setting", so that bridge users always get an address if there is one available.

I don't want to do this as part of #17840, because I'm not sure if it's really necessary - bridges just seem to work ok as-is.

Child Tickets

Change History (2)

comment:1 in reply to:  description Changed 3 years ago by teor

Replying to teor:

  • use ClientPreferIPv6ORPort to choose a preferred address for bridge clients,

And ClientUseIPv4 and ClientUseIPv6.

comment:2 Changed 3 years ago by teor

Resolution: duplicate
Status: newclosed

Oops, duplicate of #17854.

Note: See TracTickets for help on using tickets.