Opened 5 years ago

Closed 5 years ago

#17893 closed defect (fixed)

Stop building and testing Tor twice when running distcheck

Reported by: cypherpunks Owned by:
Priority: Low Milestone: Tor: 0.2.8.x-final
Component: Core Tor/Tor Version: Tor: unspecified
Severity: Trivial Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

In commit 9f6b9e28ccfdc3a96fb6e28d5121539f3cba3c55 the steps for putting out a new Tor release changed from running make check to make distcheck. With this change there is no need for the dist rule in Makefile.am:76 anymore.

The rule causes Tor to be built and tested twice when make distcheck is called (once in the current build directory and other time in the temporary distcheck build directory). This is caused by the distcheck rule calling our dist rule which calls the internal check rule which triggers the all rule.

The removal would make the workflow of testing build configuration changes faster (especially on slower machines) by not having to wait on the first compilation and testing phase which is performed by distcheck anyway.

Child Tickets

Attachments (1)

0001-Stop-building-and-testing-Tor-twice-with-distcheck.patch (551 bytes) - added by cypherpunks 5 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 Changed 5 years ago by cypherpunks

Status: newneeds_review

Attached a trivial patch for a trivial ticket :)

comment:2 Changed 5 years ago by nickm

Resolution: fixed
Status: needs_reviewclosed

We haven't forgotten to run distcheck in ages, so applying this one. Should save me a little time. Thanks!

Note: See TracTickets for help on using tickets.