Opened 5 years ago

Closed 5 years ago

#17900 closed task (duplicate)

Developer ID and Gatekeeper - Apple Developer

Reported by: cypherpunks Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Tor Browser should start to be signed using Developer ID. It can't and mustn't be assumed that users of OS X understand digital signatures or that users bear understanding or permission to begin authenticatng Tor Browser using tools from third parties on their local computer or other computers. Standard users on OS X in particular can't do this. It also doesn't cater for Standard users unable to install Tor Browser because of a local Administrator blocking it as it's unsigned or Gatekeeper blocking it.

Tor Browser for Windows is signed using a product from DigiCert. It's inconsistent not to start doing it for OS X too and it's not difficult to get a Developer ID from Apple.

It also helps stop users starting habitual behaviors of using unsigned products and helps strengthen Tor Browser against third parties distributing it as it might be unsafe. Onion Browser for iOS has this problem despite it being on App Store and The Pirate Bay did it using a customized Tor Browser and naming it PirateBrowser.

Child Tickets

Change History (1)

comment:1 Changed 5 years ago by yawning

Resolution: duplicate
Status: newclosed

Duplicate of #6540.

Note: See TracTickets for help on using tickets.