Opened 23 months ago

Last modified 23 months ago

#17968 new defect

Orbot fails to start with `java.io.FileNotFoundException: armeabi/tor.mp3`

Reported by: strugee Owned by: n8fr8
Priority: Medium Milestone:
Component: Applications/Orbot Version:
Severity: Major Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I'm trying to use Orbot on two Android devices. One is a Nexus 9 running stock Android 5.0.2, and the other is a Nexus 6P running the nightly build of CyanogenMod 13 (based on Android 6.0.1), built 12/13/2015. Orbot 15.0.1-RC-3-PIE (Tor 0.2.6.10) is installed from F-Droid on both devices.

When I start Orbot on either of these devices, I get the same exception - something about not being able to find tor.mp3. Here's the log, which is identical on both devices:

checking binary version: null
upgrading binaries to latest version: 0.2.6.10
There was an error installing Orbot binaries
Orbot is starting…
Orbot is starting…
checking binary version: null
upgrading binaries to latest version: 0.2.6.10
Unable to start Tor: java.io.FileNotFoundException: armeabi/tor.mp3
Set background service to FOREGROUND
TorService is shutting down
Orbot is deactivated
Orbot is starting…
Orbot is starting…
checking binary version: null
upgrading binaries to latest version: 0.2.6.10
Unable to start Tor: java.io.FileNotFoundException: armeabi/tor.mp3
Set background service to FOREGROUND
TorService is shutting down
Orbot is deactivated

I suspect what's happening is that both of these devices have newer architectures and for some reason tor.mp3 is getting put in some architecture-specific location. But I'm really not enough of an expert to tell for sure.

Child Tickets

Change History (3)

comment:1 Changed 23 months ago by poly

Seeing a very similar bug on my Android emulator. Downloading the latest version of Orbot (15.0.1-RC-3-PIE) from FDroid results in:

Unable to start Tor: java.io.FileNotFoundException: x86/tor.mp3

strugee, btw the file is actually a .zip, but has an mp3 extension due to legacy reasons.

Please also note that this bug in not present in the identically named version of Orbot that is older and 0.1 MB smaller.

Last edited 23 months ago by poly (previous) (diff)

comment:2 Changed 23 months ago by n8fr8

We have a new alpha release out for testing:
https://lists.mayfirst.org/pipermail/guardian-dev/2016-January/004580.html

Please do a clean install from the APK link in the announcement, and let me know if it resolves the issue.

comment:3 in reply to:  2 Changed 23 months ago by strugee

Replying to n8fr8:

Please do a clean install from the APK link in the announcement, and let me know if it resolves the issue.

Yeah, that resolves it. Thanks!

Note: See TracTickets for help on using tickets.