Opened 4 years ago

Closed 17 months ago

#18002 closed task (wontfix)

move away from OFTC to new functional, Tor-friendly IRC network

Reported by: adrelanos Owned by:
Priority: Medium Milestone:
Component: Archived/operations Version:
Severity: Normal Keywords: archived-closed-2018-07-04
Cc: ahf, whonix-devel@…, tyseom, arma Actual Points:
Parent ID: Points:
Reviewer: Sponsor: None

Description

Everyone having issues using current OFTC. This is not a support issue. The problem is with OFTC blocking Tor connections. Not configuration.

I am not positive about this situation to improve over time. Enough time has passed. OFTC does not seem to care/prioritize this issue enough. I think it's well justified to make the change.

Ideally, the whole Tor community (Torproject, Tails, Whonix, Qubes, ...) would switch to a new, functional, Tor-friendly IRC network.

Child Tickets

Change History (24)

comment:1 Changed 4 years ago by yawning

Is there an IRC network that won't start blocking Tor connections when the usual suspects get unhappy and decide to spam/DoS the IRC channels/servers?

comment:2 Changed 4 years ago by tyseom

Cc: tyseom added

comment:3 Changed 4 years ago by cypherpunks

What about https://www.hackint.org/? The only problem might be that they are relatively small currently.

comment:4 Changed 4 years ago by cypherpunks

Hackint requires SASL auth for connections from Tor (and registration over clearnet in this case), so I don't think it's an appropriate choice here. In addition, what will Hackint do if someone starts brute-forcing accounts over SASL? That's why Freenode turned off Tor connections, from what I understand.

comment:5 Changed 4 years ago by cypherpunks

Hackint requires SASL auth for connections from Tor

They have .onion for Tor users with no auth forced.

comment:6 Changed 4 years ago by bugzilla

Tor Team should show everyone how to provide public chat for Tor users, isn't it?
Or just write in Contacts that they cannot provide IRC/chat for Tor users.

comment:7 Changed 4 years ago by cypherpunks

Component: generalPonies
Keywords: bug-no-bounty unicorns added

comment:8 Changed 4 years ago by arlolra

For what it's worth, the situation seems much improved over the past few days.

comment:9 Changed 4 years ago by bugzilla

Component: Ponies- Select a component
Keywords: bug-no-bounty unicorns removed
Status: newneeds_information

What was improved?

comment:10 Changed 4 years ago by arlolra

They no longer seem to be preventing new connections from Tor.

comment:11 Changed 4 years ago by rl1987

Component: - Select a componentoperations
Sponsor: None

comment:12 Changed 3 years ago by adrelanos

OFTC is blocking Tor again. Just as Griffin and probably others, I have given up using IRC.

comment:13 Changed 3 years ago by cypherpunks

(quotes collection):
"Sign in to OFTC with your Google+ OAuth"
As of 2017-03-26, NickServ will require nick verification via services.oftc.net for the +R user mode. This affects channels using the +M and +R channel modes.
a lot of ordinary new participants will just walk away because verification is oppressive
but not to spammers etc, who are more highly motivated
well and #tor will just stay +R, which harms it the most due to it being full of people who often do not want javascript enabled :/

comment:14 Changed 3 years ago by cypherpunks

dwfreed said. oftc's ir.cop:

IRC is not a democracy, especially not OFTC
I don't care what you think

comment:15 Changed 3 years ago by cypherpunks

oftc and PRIVACY:

    if (((i = can_join(source_p, chptr, key)) && !IsGod(source_p)))
    {
      sendto_one(source_p, form_str(i), me.name,
                 source_p->name, chptr->chname);
      if(i == ERR_TOOMANYCHANNELS)
          break;
      else
          continue;
    }

    if(i != 0 && IsGod(source_p) && MyClient(source_p))
    {
      char tmp[IRCD_BUFSIZE];
      ircsprintf(tmp, "%s is using God mode: JOIN %s", source_p->name,
          chptr->chname);
      sendto_gnotice_flags(UMODE_SERVNOTICE, L_ALL, me.name, &me, NULL,
          tmp);
      oftc_log(tmp);
    }

comment:16 Changed 3 years ago by cypherpunks

UMODE_INVISIBLE yet

comment:17 Changed 3 years ago by cypherpunks

dwfreed said, golden collection oftc's ir.cop:

<dwfreed> besides, what is against the rules is whatever the opers say is

comment:18 Changed 3 years ago by vynX

Please also consider about.psyc.eu/IRC#Using_IRC_in_a_post-Snowden_world
Suggestion: Make a standalone torproject IRC server.

comment:19 Changed 3 years ago by arma

Two thoughts:

A) OFTC has its issues but on the whole it's been quite pleasant compared to other irc networks. So I would worry about the case where we move somewhere, the new place turns out to not be able to handle all of our issues, and then we don't have anyplace to move back to because we burned our bridges. I think any move we might make should have a good answer for this concern.

B) Longer term, I think we need somebody to build the irc proxy + nymble idea. That is, we need an irc proxy that can accept connections from Tor users, allow them to authenticate using some variant of the anonymous credentials idea, and then pass their connections (or their traffic, or however it works) to the main irc network. Then if they get blacklisted from the main irc network, the proxy notices and revokes their credentials.

I guess item 'B' is one instance of the more general "irc needs to gain better abuse handling mechanisms" goal. I'd love for somebody to work on it, but so far it hasn't been something that Tor has developers for.

comment:20 Changed 3 years ago by arma

Cc: arma added

comment:21 Changed 3 years ago by ahf

Cc: ahf added

comment:22 Changed 3 years ago by cypherpunks

Last edited 2 years ago by cypherpunks (previous) (diff)

comment:23 Changed 3 years ago by cypherpunks

Last edited 2 years ago by cypherpunks (previous) (diff)

comment:24 Changed 17 months ago by teor

Keywords: archived-closed-2018-07-04 added
Resolution: wontfix
Status: needs_informationclosed

Close all tickets in archived components

Note: See TracTickets for help on using tickets.