Opened 5 years ago

Closed 5 years ago

#18005 closed defect (not a bug)

Set India IP - Takes Japan IP

Reported by: patkim Owned by: tbb-team
Priority: Medium Milestone: Tor: 0.2.8.x-final
Component: Core Tor/Tor Version: Tor: 0.2.6.10
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I set India IP ExitNodes {in} StrictExitNodes 1 in my torrc file. However with this configuration it is taking an IP 120.29.xxx.xxx whose reverse look up shows in originates in Japan Tokyo. Is this a bug?
Kindly confirm. I am using Tor Browser 5.0.6 on Windows 7.
Thanks,
Pat

Child Tickets

Change History (5)

comment:1 Changed 5 years ago by kleft

I can imagine this could may be an inaccuracy of the geoip-db used by Tor. Several public db lists contain an indian location for 120.29.212.x - 120.29.221.x although they are actually operated from different countries according to the APNIC Whois. Traceroutes from de_DE to .217 end up in Tokyo while connections to .212 were served from Mumbai.

inetnum netname country nic-hdl
120.29.212.0/24 VOICEPE2_CHN-TATAC IN IA75-AP
120.29.213.0/24 VOICEPE2_MUM-TATAC IN IA75-AP
120.29.214.0/24 SGP-SVQ-TATAC SG IA75-AP
120.29.215.0/24 SGP-SVQ-TATAC SG IA75-AP
120.29.216.0/24 HONGKONG-HK2-TATAC HK IA75-AP
120.29.217.0/24 TOKYO-TV2-TATAC JP IA75-AP
120.29.218.0/24 VOICEPE_MUM-TATAC IN IA75-AP
120.29.219.0/24 SYDNEY-1MH-TATAC AU IA75-AP
120.29.220.0/24 VOICEPE_CHN-TATAC IN IA75-AP
120.29.221.0/24 SYDNEY_NGN_GEAR-TATAC AU IA75-AP
120.29.222.0/24 BANGKOK-BK7-TATAC TH IA75-AP

Edit: Indeed, when connecting with ExitNodes {in}, I got an IP from 120.29.217. and therefore a "Japan" IP-Location

Last edited 5 years ago by kleft (previous) (diff)

comment:2 Changed 5 years ago by teor

Component: Tor BrowserTor
Milestone: Tor: 0.2.8.x-final
Version: Tor: 0.2.6.10

This is not a bug with Tor Browser, it is an issue with tor's GeoIP files.

Unfortunately, GeoIP lists are somewhat inaccurate, and are becoming more so as IPv4 addresses are transferred around the world due to the IPv4 address shortage.

Also, some IP addresses have a GeoIP location based on the location of the company that controls the address, rather than the server the address is assigned to.

We regularly update the GeoIP files that are distributed with Tor, and those updates are picked up by Tor Browser. (The GeoIP files in Tor Browser 5.0.6 were updated on 1 December 2015.)

You might try reporting these issues to MaxMind. (Tor sources its GeoIP data from MaxMind.)
https://support.maxmind.com/geoip-data-correction-request/

Otherwise, I'm not sure there is anything else we can do about this, but I'm leaving this issue open in case anyone else has any suggestions.

comment:3 Changed 5 years ago by patkim

Thank you so much for the detailed explanation. This prompted me to comment out those lines in the geoip file against IN. Now when I run Tor browser, it takes some other IP for India that actually originates in India.

comment:4 Changed 5 years ago by arma

I suggest closing the ticket -- I agree that there isn't anything specific we can do on our end.

comment:5 Changed 5 years ago by teor

Resolution: not a bug
Status: newclosed
Note: See TracTickets for help on using tickets.