Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#18028 closed defect (user disappeared)

Tor 0.2.7.6 uses 100% of CPU all the time!

Reported by: cypherpunks-duplicate Owned by:
Priority: Medium Milestone: Tor: 0.2.7.x-final
Component: Core Tor/Tor Version:
Severity: Major Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

https://tor.stackexchange.com/questions/9209/tor-0-2-7-6-uses-100-of-cpu-all-the-time

I just updated my Tor with tor-0.2.7.6.tar.gz, but when I run tor, it uses 100% of one of my CPU's cores, even if I run something simple like tor --version. What is going on?

I use Slackware and used the Tor SlackBuild to build it.

Try to remove --enable-openbsd-malloc option

Why would that fix it?

Because I had a similar problem, and I solved, after some tests, just like that.

Child Tickets

Change History (6)

comment:1 Changed 4 years ago by nickm

Is this happening for anybody else?

When it's using all the cpu, could somebody try using oprofile or prof or gdb or anything to figure out where it's going?

What's the last version that _didn't_ have this problem for you?

comment:2 Changed 4 years ago by nickm

Milestone: Tor: 0.2.7.x-final
Severity: NormalMajor
Status: newneeds_information

comment:3 Changed 4 years ago by cypherpunks

Last edited 4 years ago by cypherpunks (previous) (diff)

comment:4 Changed 4 years ago by nickm

Resolution: user disappeared
Status: needs_informationclosed

comment:5 Changed 3 years ago by cypherpunks

Someone report this to IRC. They used Debian testing, x86_64 and tor compiled with enable-openbsd-malloc. They said if to attach gdb tor seems to be looping in calloc. They changed CFLAGS to "-O1" to fix issue. They thinks it's a compiler bug.

comment:6 Changed 3 years ago by cypherpunks

See #20424 for details.

Note: See TracTickets for help on using tickets.