Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#18030 closed defect (fixed)

Favicons loaded via the Page Info dialog are going over the catch-all circuit

Reported by: gk Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-linkability, TorBrowserTeam201602R
Cc: arthuredelstein, mcs, brade Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by gk)

Load https://trac.torproject.org and observe that the favicon is getting loaded over the circuit used for all the other resources of trac.torproject.org. Now, open the Page Info dialog and the favicon that gets loaded again goes over the catch-all circuit. I think the expected behavior is to let the request go over the circuit for the URL bar domain of the page in question as well.

Child Tickets

Change History (9)

comment:1 Changed 4 years ago by gk

Description: modified (diff)

comment:2 Changed 4 years ago by arthuredelstein

Keywords: tbb-linkability. TorBrowserTeam201601R added; tbb-linkability removed
Status: newneeds_review

comment:3 Changed 4 years ago by gk

Keywords: TorBrowserTeam201602R added; TorBrowserTeam201601R removed

Carrying over review tickets.

comment:4 Changed 4 years ago by bugzilla

Keywords: tbb-linkability added; tbb-linkability. removed
Summary: Favicons loaded via the Page Info dialog are not going over the same circuit as the URL bar domainFavicons loaded via the Page Info dialog are going over the catch-all circuit

comment:5 Changed 4 years ago by gk

Cc: mcs brade added

Looks good to me. mcs/brade could you have a second look?

comment:6 Changed 4 years ago by brade

r=brade, r=mcs
It would be good if we had some tests to know that this patch doesn't regress prior work. Also, tests would be useful as we move to ESR45. :-)

comment:7 in reply to:  6 Changed 4 years ago by arthuredelstein

Replying to brade:

r=brade, r=mcs
It would be good if we had some tests to know that this patch doesn't regress prior work. Also, tests would be useful as we move to ESR45. :-)

That's a good reminder. I'll work on that and post something for #16728.

comment:8 Changed 4 years ago by gk

Resolution: fixed
Status: needs_reviewclosed

Applied to tor-browser-38.6.1esr-6.0-1 (222689b3944533ebb97c809b8b6f508975dd45e3) and tor-browser-38.6.1esr-5.5-1 (b9e7d044aa52c8cda48c73616d70324f666fe1e7), thanks.

comment:9 Changed 4 years ago by cypherpunks

Did this patch fix it for all media or just images? Because, according to the logs, I see in Tor Browser 5.5.4 that images go through the first-party domain circuit, but other media such as HTML5 <video> and <audio> sources fall into the "catchall" circuit (the first-party domain seems to be "--unknown--").

Ah, I see that someone already reported this: #18703.

Last edited 4 years ago by cypherpunks (previous) (diff)
Note: See TracTickets for help on using tickets.