Opened 4 years ago

Closed 2 years ago

#18034 closed enhancement (wontfix)

the five manipulation eyes (theoretical anonymity enhancement)

Reported by: bo0od Owned by:
Priority: Medium Milestone:
Component: Circumvention/Censorship analysis Version:
Severity: Normal Keywords:
Cc: proper Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Note:- maybe you need to have knowledge about Qubes or multiple isolated VM concept to get what i mean (but not necessarily).

i was thinking of a theoretical protection against the ISP sniffing or reduce the attacking threat of the ISP to my connection. so i have an idea but i dont know if its going to work , but here it is:-

the idea needs Qubes OS , TorVM and/or Whonix

if we can have more than one Tor connection on a different VMs inside Qubes let say five , which r all opened together at the same time or gradually (1 then 2 then 3 ...) and including my connection among one of them. in another word:-

1- Tor VM (not mine)
2- Tor VM (not mine)
3- Tor VM (my connection)
4- Tor VM (not mine)
5- Tor VM (not mine)

wouldnt that increase our anonymity by increasing the surface of connectors/connection points to Tor? (which for sure one of these connections r my real connection but i dont have one connection only , instead i have five and im only using one).

to make this more efficient to use theory:-

1- the manipulated virtualmachines are not in a true storage , but they only need a fixed storage which mean we need only a disposable non-persistent storage (amnesic VM and Qubes provide this type of VM).

2- these manipulated virtualmachines WONT be useable by human. they are there just for the sake of its purpose. which will give us the opportunity to put these virtualmachines in the lowest consuming resources (RAM , Processor ...etc) so no files or media players or ...etc (so even low storage).

3- to harden these virtualmachines we can make the design of whonix as a mini-whonixes to be used from these VMs:-

Note:- we can use this design in case that just opening Tor wont manipulate anything , but if we open Tor + TBB and surfing X or Y website then we will have this method/theory to work.

(X , Y , Z ,V = just random websites.)

1- GW (Tor) - WS (TBB + X website) (disposable VM)
2- GW (Tor) - WS (TBB + Y website) (disposable VM)
3- GW (Tor) - WS (TBB + my surfing) (normal VM)
4- GW (Tor) - WS (TBB + Z website) (disposable VM)
5- GW (Tor) - WS (TBB + V website) (disposable VM)

.....etc from hardening things we can put inside this theory. but i dont know if its going to be effective or not , and what will the ISP see when we apply this.

Child Tickets

Attachments (1)

TorFuture.png (114.4 KB) - added by bo0od 4 years ago.
image of the theoritical design

Download all attachments as: .zip

Change History (9)

comment:1 Changed 4 years ago by bo0od

Milestone: Tor: unspecified
Priority: MediumHigh

comment:2 Changed 4 years ago by teor

Component: Tor- Select a component
Milestone: Tor: unspecified
Priority: HighMedium
Version: Tor: unspecified

This appears to be a duplicate of #18121, similar comments apply.

comment:3 Changed 4 years ago by bo0od

Last edited 4 years ago by bo0od (previous) (diff)

comment:4 in reply to:  2 Changed 4 years ago by bo0od

Replying to teor:

This appears to be a duplicate of #18121, similar comments apply.

it may looks similar , but they r not the same in the results.

i will draw an image for this idea in the coming two days.

Last edited 4 years ago by bo0od (previous) (diff)

comment:5 Changed 4 years ago by yawning

Hm. I'm not really sure what sort of threat model this is effective against. If your ISP is the biggest threat (and they can only see the link to the Guard), use an obfuscated transport.

The approach you describe could be replicated in code that only runs on a single client instance and a bunch of Bridges, without wasting interior/Exit bandwidth.

comment:6 Changed 4 years ago by cypherpunks

Component: - Select a componentCensorship analysis

Changed 4 years ago by bo0od

Attachment: TorFuture.png added

image of the theoritical design

comment:7 Changed 4 years ago by bo0od

sorry for taking long time , this is the image of my theoretical design.(uploaded)

comment:8 Changed 2 years ago by dcf

Resolution: wontfix
Status: newclosed

As in comment:8:ticket:18121, moving to the "Obfuscation" component, even though it's not a perfect match for what else is in Obfuscation.

Note: See TracTickets for help on using tickets.