Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#1804 closed defect (not a bug)

I can't get a relay going

Reported by: skaifenix Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Keywords: tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by phobos)

My relay and directory ports are 030 and 09050 if i hange to say 443 it refuses twith a message we can't do it, blah blah, I also get the proxy is refusing connections.

Child Tickets

Change History (8)

comment:1 Changed 9 years ago by skaifenix

My relay and directory ports are 9030 and 9050 if i change to say 443 it refuses with a message -we can't do it, blah blah,- I also get the proxy is refusing connections error with the Torbutton on.

comment:2 in reply to:  1 Changed 9 years ago by phobos

Description: modified (diff)

Replying to skaifenix:

My relay and directory ports are 9030 and 9050 if i change to say 443 it refuses with a message -we can't do it, blah blah,- I also get the proxy is refusing connections error with the Torbutton on.

We need much more information. What errors show up in your log, which operating system, how are you configuring the relay?

comment:3 Changed 9 years ago by arma

My guess is the user is on Linux or OS X, and the Tor user can't bind to port 443 because it's a privileged port.

As for the Torbutton complaint, my guess is the user hasn't set up Tor, Polipo, Firefox, and Torbutton according to the instructions.

Sounds like a good candidate for closing.

comment:4 Changed 9 years ago by arma

Original poster answered with

"I am using OSX! What port shall i choose? Direction please, thks!"

comment:5 in reply to:  4 Changed 9 years ago by arma

Replying to arma:

Original poster answered with

"I am using OSX! What port shall i choose? Direction please, thks!"

(Please reply on trac.torproject.org in the future, so we can keep everything in this thread.)

On OS X, your best bet is to choose the default port -- 9001. It should work smoothly then.

As for using Tor as a client, https://www.torproject.org/docs/tor-doc-osx should walk you through all the steps. I'm afraid our OS X bundles over the years have sometimes been pretty bad, and upgrades have sometimes been pretty rough. Things should be a bit better now I hope.

comment:6 Changed 9 years ago by nickm

Resolution: not a bug
Status: newclosed

The "can't d o it bla bla bla" is probably trying to open 443 as a nonprivileged user. No bug here.

If the instructions above didn't help you get a relay set up, feel free to ask for more help on the or-talk mailing list or the IRC channel, both of which get answered much faster. Also, if you get specific errors that you need help with, remember to copy the exact error message : it might just look like "bla bla bla" to you, but it is usually something that other people will need in order to understand what's going wrong for you.

Cheers,

  • Nick

comment:7 Changed 7 years ago by nickm

Keywords: tor-relay added

comment:8 Changed 7 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.