Opened 21 months ago

Last modified 4 months ago

#18048 new defect

Update Atlas's jQuery

Reported by: cypherpunks Owned by: RaBe
Priority: Low Milestone:
Component: Metrics/Atlas Version:
Severity: Minor Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When i go to https://globe.torproject.org/ the warning

Use of getPreventDefault() is deprecated. Use defaultPrevented instead.

shows up in the browser console. I managed to track this warning back to jQuery which has a ticket for it. This issue has been fixed in jQuery 1.11. FWICT Globe uses jQuery 1.10.2.

Child Tickets

Change History (6)

comment:1 Changed 21 months ago by isis

Priority: MediumLow
Severity: NormalMinor
Summary: Deprecated function warning when loading GlobeUpdate Globe's jQuery

comment:2 Changed 17 months ago by karsten

Component: Metrics/GlobeMetrics/Atlas
Owner: changed from isis to phw

We're about to retire Globe soon, but it looks like Atlas has the same issue with an outdated jQuery. It's using jQuery 1.7.1, I think. Changing to the Atlas component.

comment:3 Changed 8 months ago by cypherpunks

Summary: Update Globe's jQueryUpdate Atlas's jQuery

comment:4 Changed 8 months ago by RaBe

Owner: changed from phw to RaBe
Status: newassigned

comment:5 Changed 5 months ago by RaBe

Status: assignednew

comment:6 Changed 4 months ago by jvoisin

My instance of Atlas is running with the latest jQuery 1.X version (1.12.4), and everything is working :)

Note: See TracTickets for help on using tickets.