Opened 4 years ago

Closed 23 months ago

#18075 closed defect (wontfix)

Vagrant-Based Tor Browser Bundle Instructions Are Out of Date

Reported by: miserlou Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-gitian
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

It seems the TBB build instructions are out of date. What is the best procedure for building TBB right now?

Expected Result:
A clean build of Tor Browser Bundle.

Actual Result:
vagrant ssh --command "cd ~/tor-browser-bundle/gitian && USE_LXC=1 make"
rm -f ../../gitian-builder/inputs/bundle-*
rm -f ../../gitian-builder/inputs/*utils.zip
rm -f ../../gitian-builder/inputs/tor-linux*
rm -f ../../gitian-builder/inputs/tor-mac*
rm -f ../../gitian-builder/inputs/tor-win*
rm -f ../../gitian-builder/inputs/tor-browser-linux*
rm -f ../../gitian-builder/inputs/tor-browser-mac*
rm -f ../../gitian-builder/inputs/tor-browser-win*
rm -f ../../gitian-builder/inputs/mar-tools-*
rm -f ../../gitian-builder/inputs/pluggable-transports*
rm -f ../../gitian-builder/inputs/*.yml
rm -f ../../gitian-builder/inputs/bundle.inputs
rm -f ../../gitian-builder/inputs/versions*
./check-prerequisites.sh
Your Ubuntu is too old. You need Ubuntu 14.04 LTS or newer to build Tor Browser with Gitian.
make: * [prep] Error 1
Connection to 127.0.0.1 closed.
make:
* [tbb] Error 2

To reproduce:
git clone https://git.torproject.org/builders/tor-browser-bundle.git
cd vagrant
make

Related to https://trac.torproject.org/projects/tor/ticket/18074

Child Tickets

Change History (3)

comment:1 Changed 3 years ago by krichter

I don't find any build instructions at all. I'm asking because I'd open an issue for creating such if you confirm that there're none in the READMEs.

comment:2 Changed 3 years ago by gk

Keywords: tbb-gitian added; tbb tor-browser-bundle browser removed

comment:3 Changed 23 months ago by gk

Resolution: wontfix
Status: newclosed

We are switching to rbm where those issues are no concern (anymore). We won't fix those.

Note: See TracTickets for help on using tickets.