Opened 5 years ago

Last modified 18 months ago

#18106 new enhancement

Rename fascist_firewall_* functions to reachable_address_*

Reported by: teor Owned by:
Priority: Low Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Trivial Keywords: easy, minor, rename, tor-relay
Cc: Actual Points:
Parent ID: Points: small
Reviewer: Sponsor:


In #17840 and #9067 / #9068, we unified ReachableAddresses and ClientUseIPv4/ClientUseIPv6/UseBridges. We'd previously unified FascistFirewall, FirewallPorts and ReachableAddresses.

This means that the functions called fascist_firewall_* should probably be renamed to be more descriptive.

I think reachable_address_* is one option, but let's follow typical naming standards and not repeat words in names:

  • fascist_firewall_choose_address_dir_server ->
  • reachable_address_choose_address_dir_server ->
  • reachable_address_choose_dir_server

Let's also use this as an opportunity to disambiguate fascist_firewall_choose_address_impl & fascist_firewall_choose_address_base.

Child Tickets

Change History (9)

comment:1 Changed 5 years ago by nickm

Milestone: Tor: 0.2.8.x-finalTor: 0.2.???

It is impossible that we will fix all 277 currently open 028 tickets before 028 releases. Time to move some out. This is my first pass through the "new" and "reopened" tickets, looking for things to move to ???.

comment:2 Changed 5 years ago by nickm

Priority: MediumLow

comment:3 Changed 5 years ago by nickm

Points: small

comment:4 Changed 4 years ago by teor

Milestone: Tor: 0.2.???Tor: 0.3.???

Milestone renamed

comment:5 Changed 4 years ago by nickm

Keywords: tor-03-unspecified-201612 added
Milestone: Tor: 0.3.???Tor: unspecified

Finally admitting that 0.3.??? was a euphemism for Tor: unspecified all along.

comment:6 Changed 3 years ago by nickm

Keywords: tor-03-unspecified-201612 removed

Remove an old triaging keyword.

comment:7 Changed 3 years ago by nickm

Keywords: minor rename tor-relay added
Severity: NormalTrivial

comment:8 Changed 18 months ago by eucalyptus

Hi, I'd like to do this issue. Should I branch off of master, or a specific version or release?

comment:9 Changed 18 months ago by nickm

Branches like this should be based on master.

As you do this, remember that this ticket is only about renaming stuff in the code -- user-facing options are separate.

Best wishes!

Note: See TracTickets for help on using tickets.