Opened 3 years ago

Closed 10 months ago

Last modified 10 months ago

#18122 closed enhancement (wontfix)

Show prefetched new Tor circuit

Reported by: bugzilla Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-circuit-display, tbb-usability, tbb-performance
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

It takes noticeable time for Tor Browser to create a new Tor circuit and then for loading / reloading a webpage. So, UX can be improved by prefetching one circuit and having it ready before user request.

Child Tickets

Change History (11)

comment:1 Changed 3 years ago by teor

Component: Tor BrowserTor
Resolution: implemented
Status: newclosed

Tor attempts to keep open Exit circuits for every port used in the past hour, and has done this since at least version 0.0.9 (commit d2400a5af, 18 Jan 2005).

See the function circuit_predict_and_launch_new(), and the man page description for PredictedPortsRelevanceTime, and the hidden torrc option DisablePredictedCircuits.

comment:2 Changed 3 years ago by bugzilla

Lag of changing circuit in circuit visualizer is so obvious that I preferred not to go deeply into the problem (sorry). It's good that Tor has full support of prefetching, but the ticket is about Tor Browser, UX and, maybe, its integration with Tor.
If circuit is prefetched, then it will be good if user can see it in a new tab, even if no page was loaded.
The main proposal is to make circuit visualizer show situation with circuits in real-time.
There is a ticket close to this: no visual circuit if SSL error or similar. It complements this ticket in a part of preserving visualization of the current circuit until new circuit will be allocated to the tab.

Last edited 3 years ago by bugzilla (previous) (diff)

comment:3 Changed 3 years ago by bugzilla

Component: TorTor Browser
Keywords: tbb-circuit-display tbb-usability added
Resolution: implemented
Status: closedreopened
Summary: Prefetch new Tor circuitShow prefetched new Tor circuit

comment:4 in reply to:  description Changed 3 years ago by cypherpunks

It is rare that circuit creation is slow. What usually happens is that the network connection times out after Tor attaches the stream to a circuit (the timeout is normally 10s). If that happens, Tor will retry with a new circuit.

Some exit nodes appear to be blackholed by some destinations and don't receive any network replies. In this case you will get the timeouts.

I often monitor timestamped Tor control STREAM and CIRC events, so I know where the delay is.

Your UI suggestions in comment 2 don't make much sense. Idle prebuilt circuits are assigned opportunistically and may be used by an existing tab or some other application or Tor may have to create a new one if the exit relay doesn't support the target port.

comment:5 Changed 2 years ago by bugzilla

Resolution: duplicate
Status: reopenedclosed

Duplicate of #15897.

comment:6 Changed 11 months ago by cypherpunks

Resolution: duplicate
Status: closedreopened

Check #18859

comment:7 Changed 11 months ago by gk

Resolution: duplicate
Status: reopenedclosed

Closing this as duplicate of #18859 then. (I guess that's what you meant?)

comment:8 Changed 10 months ago by cypherpunks

Resolution: duplicate
Status: closedreopened

No, it was a duplicate of #15897, until you closed that with

New tabs don't have domains in their URL bar.

but despite that, they have pre-built circuits now (thanks to #18859).

comment:9 Changed 10 months ago by gk

Resolution: wontfix
Status: reopenedclosed

I think I agree with comment:4.

comment:10 Changed 10 months ago by cypherpunks

I think this is a second time I see all other developers said there's nothing to fix, except Arthur who finally fixed the issue. (comment:4 has nothing about isolated circuits)

comment:11 in reply to:  10 Changed 10 months ago by gk

Replying to cypherpunks:

I think this is a second time I see all other developers said there's nothing to fix, except Arthur who finally fixed the issue. (comment:4 has nothing about isolated circuits)

I think you are wrong here. If you think I or someone else misunderstood you please reopen the ticket and explain what you mean (explaining as well my understanding of your issue was wrong). And, no, new tabs don't have pre-built circuits either. Ctrl+t does not interact with tor in any way. Thus, there is nothing the circuit display could reasonably show in this case.

And please don't put multiple issues in a single bug (or hijack a bug). I've told that to you (yes, you, even though you are behind the cypherpunks account) numerous times. It makes dealing with bugs harder, error-prone and there is the risk that things are falling through the cracks. Thanks.

Note: See TracTickets for help on using tickets.