Opened 9 years ago

Closed 8 years ago

#1813 closed defect (fixed)

Polipo gives bus error on MacOS 10.4.11

Reported by: bluejoule Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version: Tor: 0.2.1.26
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hope this is the right spot for this report - I went to the Polipo website and it told me to report it here. I'll be happy with either a) a version of Polipo which works with the 10.4.11 Mac OS or b) the knowledge that if I upgrade that Mac to Snow Leopard (10.6.4) that the Polipo / Tor combination will work.

I downloaded the MacOS bundle twice today; worked fine on the 10.6.4 machine; but Tor gave errors regarding the proxy when I tried to use it on the 10.4.11 machine. I looked in the preferences and they all matched. So, I tried starting polipo on the command line (looking at the prefs in Vidalia, I used the polipo path and config file). This generated a bus error. The checksum for the polipo executable was the same on both machines; I assume therefore that there is an incompatibility with the bundled version of polipo.

Child Tickets

Change History (4)

comment:1 Changed 9 years ago by phobos

Can you attach the actual error you received? Did your mac also generate a crash report for polipo?

comment:2 Changed 9 years ago by erinn

We saw this on IRC the other day and it turned out that the problem was that Polipo is not being built with -mmacosx-version-min=10.4, at least if Sebastian is correct (which I think he is).

bluejoule, if you're downloading the Vidalia package for x86 and using it on your 10.4 machine, you might try downloading the ppc one instead (https://www.torproject.org/dist/vidalia-bundles/vidalia-bundle-0.2.1.26-0.2.8-ppc.dmg) -- our reporter on IRC said that it worked. If you're using the purely Tor bundle (like from https://www.torproject.org/dist/osx/), I will have the latest Tor alpha version available soon, with a hopefully-fixed Polipo, and you can test that.

So, all that said, I do think if you upgrade your OSX installation, you won't have any problems with Tor / Polipo / our bundles in general. We've only seen this issue from 10.4 users.

comment:3 Changed 9 years ago by rransom

Component: PolipoTor bundles/installation
Owner: set to erinn

This was a bug in our build of Polipo, not in Polipo itself.

Can this bug be closed now? I can't tell whether this is the same problem we've been seeing again recently or a different one.

comment:4 Changed 8 years ago by erinn

Resolution: fixed
Status: newclosed

This bug hasn't been reported in a while and I'm pretty sure it's no longer a problem. Closing.

Note: See TracTickets for help on using tickets.