Opened 4 years ago

Closed 3 years ago

#18153 closed defect (worksforme)

When using bridges, control port doesn't report throughput events/stats

Reported by: n8fr8 Owned by:
Priority: Low Milestone: Tor: unspecified
Component: Core Tor/Tor Version: Tor: 0.2.7.6
Severity: Normal Keywords: control, port, tor-bridge, isaremoved, tor-03-unspecified-201612
Cc: Actual Points:
Parent ID: Points: 2
Reviewer: Sponsor: SponsorS-can

Description

the bandwidthUsed() callback provides through the JTorControl library, which maps to the BW EVENt from the control port doesn't seem to send any data when bridges are used.

Is this a known behavior of Tor+bridges, or is there a bug somewhere?

Child Tickets

Change History (12)

comment:1 Changed 4 years ago by yawning

Status: newneeds_information

I can't reproduce this behavior with 0.2.7.6 using an obfs4 bridge (I get the bandwidth events that I expect), though I will admit that I didn't try very hard to get it to misbehave, and only confirmed that loading check.tp.o gave me events indicative of network use.

nb: The bandwidth values will not include pluggable transport overhead since Tor doesn't have that information, but there should always be values.

comment:2 Changed 4 years ago by nickm

Milestone: Tor: 0.2.8.x-final

comment:3 Changed 4 years ago by nickm

Milestone: Tor: 0.2.8.x-finalTor: 0.2.9.x-final

These seem like features, or like other stuff unlikely to be possible this month. Bumping them to 0.2.9

comment:4 Changed 4 years ago by nickm

Points: small/medium

comment:5 Changed 4 years ago by nickm

Priority: MediumLow

comment:6 Changed 4 years ago by nickm

Sponsor: SponsorS-can

Tagging these bridge- and PT- items as S-can.

comment:7 Changed 4 years ago by nickm

Keywords: tor-bridge added

comment:8 Changed 3 years ago by nickm

Points: small/medium2

small/medium => 2.

comment:9 Changed 3 years ago by isabela

Keywords: isaremoved added
Milestone: Tor: 0.2.9.x-finalTor: 0.2.???

comment:10 Changed 3 years ago by teor

Milestone: Tor: 0.2.???Tor: 0.3.???

Milestone renamed

comment:11 Changed 3 years ago by nickm

Keywords: tor-03-unspecified-201612 added
Milestone: Tor: 0.3.???Tor: unspecified

Finally admitting that 0.3.??? was a euphemism for Tor: unspecified all along.

comment:12 Changed 3 years ago by nickm

Resolution: worksforme
Status: needs_informationclosed

hm. n8fr8 encountered, but yawning couldn't repro. Closing this as "worksforme", but please reopen if there's a way to reproduce it.

Note: See TracTickets for help on using tickets.