Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#18171 closed defect (fixed)

Dlls brokenness with Windows10 Build 14251

Reported by: Coh_t Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Major Keywords: bounty-party borkenward-compatibility loneliness bug-no-bounty tbb-crash TorBrowserTeam201602 fuck-mingw
Cc: nickm Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I installed InsiderPreview Build 14251, and restart Machine.
Tor did not start.

I will attach the fault log XML.

Child Tickets

Attachments (6)

error.xml (970 bytes) - added by Coh_t 4 years ago.
Windows Application Error Log
error2.xml (968 bytes) - added by Coh_t 4 years ago.
new Windows Application Error Log (20160129)
4.0-alpha-1.xml (979 bytes) - added by Coh_t 4 years ago.
Windows Application Error Log @ 4.0-alpha-1
4.0.2.xml (960 bytes) - added by Coh_t 4 years ago.
Windows Application Error Log @ 4.0.2
fix.diff (10 bytes) - added by cypherpunks 4 years ago.
Windows like blackhole
d90b8bb82e.xml (1003 bytes) - added by Coh_t 4 years ago.
Windows Application Error Log @ d90b8bb82e

Download all attachments as: .zip

Change History (111)

Changed 4 years ago by Coh_t

Attachment: error.xml added

Windows Application Error Log

comment:1 Changed 4 years ago by Coh_t

Version: Tor: 0.2.6.10Tor: 0.2.7.6

Sorry. I have registered a different version.

comment:2 Changed 4 years ago by cypherpunks

Fuck windows, mingw, and everything near it.

Last edited 4 years ago by cypherpunks (previous) (diff)

comment:3 in reply to:  2 Changed 4 years ago by Coh_t

Is this will never be official binary release to change?

comment:4 Changed 4 years ago by cypherpunks

Is this will never be official binary release to change?

To be clear, offset reported by Windows for libevent-2-0-5.dll is from tor-win32-0.2.6.10.zip (built with Tor Browser 5.0), not from tor-win32-0.2.7.6.zip. (they used the same mingw tag however, but offsets are different).

Please test it with unpacked binaries for tor-win32-0.2.7.6.zip

comment:5 Changed 4 years ago by cypherpunks

tor-win32-0.2.7.6.zip

This one (.asc)

comment:6 Changed 4 years ago by Coh_t

Thank you for the changed files.

But also libevent-2-0-5.dll was abort in my environment.

comment:7 Changed 4 years ago by cypherpunks

But also libevent-2-0-5.dll was abort in my environment.

Can you attach new Windows Application Error Log?

comment:8 Changed 4 years ago by Coh_t

I attach the XML file. Please check.

Changed 4 years ago by Coh_t

Attachment: error2.xml added

new Windows Application Error Log (20160129)

comment:9 Changed 4 years ago by cypherpunks

Component: TorTor Browser
Owner: set to tbb-team

Fuck windows, mingw, and everything near it.

Last edited 4 years ago by cypherpunks (previous) (diff)

comment:10 Changed 4 years ago by cypherpunks

Summary: Tor abort Windows10 InsiderPreview Build 14251Dlls brokenness with Windows10 Build 14251
Version: Tor: 0.2.7.6

Probably related report. It doesn't crash inside crt (for exe either), but LoadLibrary fails instead.

comment:11 Changed 4 years ago by cypherpunks

comment:12 Changed 4 years ago by cypherpunks

New Windows Build might to uncover some bug in dlls, Microsoft could to cover it back in next build or not.

So what about dll entry point:

The entry-point function should perform only simple initialization or termination tasks. It must not call the LoadLibrary or LoadLibraryEx function (or a function that calls these functions), because this may create dependency loops in the DLL load order. This can result in a DLL being used before the system has executed its initialization code. Similarly, the entry-point function must not call the FreeLibrary function (or a function that calls FreeLibrary) during process termination, because this can result in a DLL being used after the system has executed its termination code.

Because Kernel32.dll is guaranteed to be loaded in the process address space when the entry-point function is called, calling functions in Kernel32.dll does not result in the DLL being used before its initialization code has been executed. Therefore, the entry-point function can call functions in Kernel32.dll that do not load other DLLs. For example, DllMain can create synchronization objects such as critical sections and mutexes, and use TLS. Unfortunately, there is not a comprehensive list of safe functions in Kernel32.dll.

Calling functions that require DLLs other than Kernel32.dll may result in problems that are difficult to diagnose. For example, calling User, Shell, and COM functions can cause access violation errors, because some functions load other system components. Conversely, calling functions such as these during termination can cause access violation errors because the corresponding component may already have been unloaded or uninitialized.

Because DLL notifications are serialized, entry-point functions should not attempt to communicate with other threads or processes. Deadlocks may occur as a result.

comment:13 Changed 4 years ago by gk

Cc: nickm added
Priority: MediumHigh
Severity: NormalMajor

comment:14 Changed 4 years ago by cypherpunks

It doesn't crash inside crt (for exe either), but LoadLibrary fails instead.

Wrong assumption, probably, still about crash. How is it crashing, logs by windows, and message boxing after that?

Last edited 4 years ago by cypherpunks (previous) (diff)

comment:15 Changed 4 years ago by cypherpunks

Couldn't load XPCOM
nspr4.dl, version 4.10.10.0, Exception code: 0xc0000005, Fault offset: 0x00020db2

comment:16 Changed 4 years ago by cypherpunks

Fuck windows, mingw, and everything near it.

Last edited 4 years ago by cypherpunks (previous) (diff)

comment:17 Changed 4 years ago by cypherpunks

Fuck windows, mingw, and everything near it.

Last edited 4 years ago by cypherpunks (previous) (diff)

comment:18 Changed 4 years ago by cypherpunks

Fuck windows, mingw, and everything near it.

Last edited 4 years ago by cypherpunks (previous) (diff)

comment:19 Changed 4 years ago by cypherpunks

Fuck windows, mingw, and everything near it.

Last edited 4 years ago by cypherpunks (previous) (diff)

comment:20 Changed 4 years ago by cypherpunks

Fuck windows, mingw, and everything near it.

Last edited 4 years ago by cypherpunks (previous) (diff)

comment:21 Changed 4 years ago by gk

Keywords: tbb-crash TorBrowserTeam201602 added

comment:22 Changed 4 years ago by bugzilla

@gk:
Have you confirmed that TBB is responsible for crash?
Win10IP is a beta and build 14251 is on fast ring (like "pre-beta"). MS known issues:

Due to a recent memory management change, you may see periodic app crashes or other memory related app errors. Rebooting your PC may correct the issue. Due to this issue, the Github client will not launch.

So, maybe, wait for beta stage at least to make conclusions?

comment:23 Changed 4 years ago by cypherpunks

Fuck windows, mingw, and everything near it.

Last edited 4 years ago by cypherpunks (previous) (diff)

comment:24 Changed 4 years ago by cypherpunks

libevent-2-0-5.dll 23604 bytes

comment:25 Changed 4 years ago by cypherpunks

Fuck windows, mingw, and everything near it.

Last edited 4 years ago by cypherpunks (previous) (diff)

comment:26 Changed 4 years ago by cypherpunks

It's chance to drop windows support!

comment:27 Changed 4 years ago by cypherpunks

@bugzilla
lets drop windows on a floor!!!!!!!!!!!

comment:28 Changed 4 years ago by cypherpunks

N

comment:29 Changed 4 years ago by cypherpunks

o

comment:30 Changed 4 years ago by cypherpunks

o

comment:31 Changed 4 years ago by cypherpunks

n

comment:32 Changed 4 years ago by cypherpunks

e

comment:33 Changed 4 years ago by cypherpunks

d

comment:34 Changed 4 years ago by cypherpunks

e

comment:35 Changed 4 years ago by cypherpunks

v

comment:36 Changed 4 years ago by cypherpunks

u

comment:37 Changed 4 years ago by cypherpunks

s

comment:38 Changed 4 years ago by cypherpunks

i

comment:39 Changed 4 years ago by cypherpunks

n

comment:40 Changed 4 years ago by cypherpunks

g

comment:41 Changed 4 years ago by cypherpunks

W

comment:42 Changed 4 years ago by cypherpunks

I

comment:43 Changed 4 years ago by cypherpunks

N

comment:44 Changed 4 years ago by cypherpunks

D

comment:45 Changed 4 years ago by cypherpunks

O

comment:46 Changed 4 years ago by cypherpunks

Z

comment:47 Changed 4 years ago by cypherpunks

E

comment:48 Changed 4 years ago by cypherpunks

.

comment:49 Changed 4 years ago by cypherpunks

Keywords: bug-no-bounty added

comment:50 Changed 4 years ago by cypherpunks

Keywords: loneliness added

comment:51 Changed 4 years ago by Coh_t

my libevent-2-0-5.dll 718072bytes 719217bytes.

Do you have that I do something?

comment:52 Changed 4 years ago by gk

We can do some testing to see whether the hardening is really the problem here. 4.0-alpha-1 is the last alpha without hardening. Could anybody having the crash problems test this one and 4.0-alpha-2?

https://archive.torproject.org/tor-package-archive/torbrowser/4.0-alpha-1/
https://archive.torproject.org/tor-package-archive/torbrowser/4.0-alpha-2/

If both are still working I would be interested to know what the fist Tor Browser version is that is broken. All previous releases can be found on https://archive.torproject.org/tor-package-archive/torbrowser/

comment:53 Changed 4 years ago by gk

Status: newneeds_information

comment:54 Changed 4 years ago by Coh_t

The 4.0-alpha-1 is crashed.

Changed 4 years ago by Coh_t

Attachment: 4.0-alpha-1.xml added

Windows Application Error Log @ 4.0-alpha-1

comment:55 Changed 4 years ago by Coh_t

The 4.0-alpha-2 appears to be connected.

comment:56 in reply to:  55 Changed 4 years ago by gk

Replying to Coh_t:

The 4.0-alpha-2 appears to be connected.

Okay if 4.0-alpha-2 is working for you (does it do so reliably) could you test later versions and report back which is the first one where Tor Browser is broken for you?

comment:57 Changed 4 years ago by Coh_t

The 4.0.2 is crashed.
However, Firefox has aborted rather than DLL.

Changed 4 years ago by Coh_t

Attachment: 4.0.2.xml added

Windows Application Error Log @ 4.0.2

comment:58 Changed 4 years ago by Coh_t

Version of Firefox is different from the 31.2 and 31.3.

comment:59 Changed 4 years ago by gk

Could you check with which Tor Browser version the libevent related crash you detected is starting?

comment:60 Changed 4 years ago by Coh_t

Version 5 or later I get a message that is "Could not load XPCOM.".

comment:61 in reply to:  59 Changed 4 years ago by Coh_t

Replying to gk:

Could you check with which Tor Browser version the libevent related crash you detected is starting?

I did not use the TorBrowser.
I used to change the Tor version with the Vidalia bundle.

I tried two different libevent-2.0.5.dll in Tor ver.0.2.6.7, 718072bytes and 719217bytes.

comment:62 Changed 4 years ago by Coh_t

tor-win32-0.2.6.1-alpha.zip in 4.0-alpha-N also aborted at libevent-2-0-5.dll.

comment:63 in reply to:  62 Changed 4 years ago by Coh_t

Sorry. tor-win32-0.2.6.1-alpha.zip is in 4.5-alpha-N.

comment:65 Changed 4 years ago by Coh_t

tor-win32-tor-0.2.5.10.zip in 4.0.1 did not abort livevent-2-0-5.dll.
But, this version is not able to connect(SSL version is old?). I wait 5minits.

tor-win32-tor-0.2.5.11.zip in 4.0.6 aborted livevent-2-0-5.dll.
tor-win32-tor-0.2.5.12.zip in 4.0.8 aborted, too.

comment:67 in reply to:  65 Changed 4 years ago by Coh_t

Sorry. tor-win32-tor-0.2.5.10.zip, I was as in normal When you start again.

comment:68 Changed 4 years ago by cypherpunks

Fuck windows, mingw, and everything near it.

Last edited 4 years ago by cypherpunks (previous) (diff)

comment:69 Changed 4 years ago by cypherpunks

Fuck windows, mingw, and everything near it.

Last edited 4 years ago by cypherpunks (previous) (diff)

comment:70 Changed 4 years ago by cypherpunks

Fuck windows, mingw, and everything near it.

Last edited 4 years ago by cypherpunks (previous) (diff)

comment:71 Changed 4 years ago by cypherpunks

Fuck windows, mingw, and everything near it.

Last edited 4 years ago by cypherpunks (previous) (diff)

comment:72 Changed 4 years ago by cypherpunks

comment:73 Changed 4 years ago by cypherpunks

This for those who will find registry key to change memory management.

comment:74 Changed 4 years ago by cypherpunks

Don't wait it too long, someone already bite it.

comment:75 in reply to:  72 Changed 4 years ago by Coh_t

I look it is delicious.

Changed 4 years ago by cypherpunks

Attachment: fix.diff added

Windows like blackhole

comment:76 Changed 4 years ago by cypherpunks

  1. Do not use pseudo-relocation
  2. Do not use Mingw
  3. Do not use Windows

Your choice.

comment:77 in reply to:  76 Changed 4 years ago by gk

Replying to cypherpunks:

  1. Do not use pseudo-relocation
  2. Do not use Mingw
  3. Do not use Windows

Your choice.

I choose 1). Now we just need a patch for that and ideally a commit that first introduced the breakage to test our assumptions.

comment:78 Changed 4 years ago by cypherpunks

You can't to link stuff by mingw properly without runtime pseudo-relocation mess. Visual Studio can.

comment:80 Changed 4 years ago by cypherpunks

Fuck windows, mingw, and everything near it.

Last edited 4 years ago by cypherpunks (previous) (diff)

comment:81 Changed 4 years ago by cypherpunks

* cypherpunks give bounty and binaries to Coh_t

Changed 4 years ago by Coh_t

Attachment: d90b8bb82e.xml added

Windows Application Error Log @ d90b8bb82e

comment:83 Changed 4 years ago by Coh_t

Microsoft began to offer a Windows 10 Build14257.
I have not yet updated.

comment:84 Changed 4 years ago by cypherpunks

Fuck windows, mingw, and everything near it.

Last edited 4 years ago by cypherpunks (previous) (diff)

comment:85 Changed 4 years ago by Coh_t

In Windows 10 Build14257 either of Tor (26525bf486 and d90b8bb82e), it is also working.

comment:86 Changed 4 years ago by Coh_t

And also working original 0.2.7.6.

comment:87 Changed 4 years ago by gk

Interesting. Could anyone test whether that resolves the issues with Tor Browser 5.5 as well?

comment:88 Changed 4 years ago by Coh_t

Tor Browser 5.5 is working.

comment:89 Changed 4 years ago by cypherpunks

Fuck windows, mingw, and everything near it.

Last edited 4 years ago by cypherpunks (previous) (diff)

comment:90 Changed 4 years ago by cypherpunks

Keywords: borkenward-compatibility added

comment:91 Changed 4 years ago by cypherpunks

Why to support broken OS?

comment:92 in reply to:  91 Changed 4 years ago by gk

Resolution: fixed
Status: needs_informationclosed

Replying to cypherpunks:

Why to support broken OS?

Because most of our user are on it. It seems Microsoft "fixed" their stuff. Closing this now, then. Thanks to all that helped investigating this.

comment:93 Changed 4 years ago by Coh_t

Is it might be a problem again by the future of the Windows Update?

comment:94 Changed 4 years ago by Coh_t

I will report when the goes wrong again.
Thanks!

comment:95 Changed 4 years ago by bugzilla

gk, why do you spend time for this MS crap? Gitians wait until new MS build...

comment:96 in reply to:  95 Changed 4 years ago by gk

Replying to bugzilla:

gk, why do you spend time for this MS crap? Gitians wait until new MS build...

Because a bunch of users of the most important OS seemed to be affected and it might be smart to understand what is going on just in case Microsoft wanted to fix their OS properly (or wants to do so in the future). This allows us to provide a patch as quickly as possible to minimize the time affected users would need to resort to a non-Tor Browser which could be pretty dangerous for them.

comment:97 in reply to:  22 Changed 4 years ago by bugzilla

Again:

@gk:
Have you confirmed that TBB is responsible for crash?
Win10IP is a beta and build 14251 is on fast ring (like "pre-beta"). MS known issues:

Due to a recent memory management change, you may see periodic app crashes or other memory related app errors. Rebooting your PC may correct the issue. Due to this issue, the Github client will not launch.

So, maybe, wait for beta stage at least to make conclusions?

And

Because a bunch of users of the most important OS

Most important OS today is Win7 (see % of users). Win10 is a crap and continues to be constantly updating crap according to MS policy. From the point of view of security Win10 is a spying blackbox, and a bunch of users using "pre-beta" with the latest spying updates are idiots and, definitely, not

most of our user are on it.

comment:98 Changed 4 years ago by cypherpunks

Fuck windows, mingw, and everything near it.

Last edited 4 years ago by cypherpunks (previous) (diff)

comment:99 Changed 4 years ago by Coh_t

I think that there is a need to investigate as much as possible as long as the abnormal behavior, even if in the beta version.
If you did not do anything, what would be a problem that does not work when the release came out.

comment:100 Changed 4 years ago by cypherpunks

And now bounty party in this ticket.
* cypherpunks give it everyone in this ticket.

comment:101 Changed 4 years ago by cypherpunks

Keywords: bounty-party added

comment:102 Changed 4 years ago by Coh_t

I thought trying to make the Tor-proxy in RPi in this matter.

comment:103 Changed 4 years ago by cypherpunks

Keywords: mingw added

comment:104 Changed 4 years ago by cypherpunks

Fuck windows, mingw, and everything near it.

Last edited 4 years ago by cypherpunks (previous) (diff)

comment:105 Changed 4 years ago by cypherpunks

Keywords: fuck-mingw added; mingw removed
Note: See TracTickets for help on using tickets.