Opened 4 years ago

Last modified 2 years ago

#18199 assigned defect

Firefox icon for browser after update

Reported by: cypherpunks Owned by: mcs
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-branding
Cc: brade, mcs, rugk, eezacque Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

After every update, when you restart tor browser it restarts with Firefox's icon instead of the default tor browser icon. Only if you close it and reopen again, it loads the default tor browser icon. From what I can see it still connects to tor even when it has the Firefox icon but is there any reason to be concerned about this?

Child Tickets

Change History (14)

comment:1 Changed 4 years ago by gk

Resolution: duplicate
Status: newclosed

I guess you are just hitting a branding issue in the "add-on compatibility" dialog. This is a duplicate of #16886 then. If that is wrong please reopen the ticket.

comment:2 Changed 4 years ago by cypherpunks

Resolution: duplicate
Status: closedreopened

That ticket says it was only for the "add-on compatibility" dialog but I see the Firefox logo during the launcher screen as well the browser after. Only if you close it and reopen again, it loads the default tor browser icon.

comment:3 in reply to:  2 Changed 4 years ago by gk

Status: reopenedneeds_information

Replying to cypherpunks:

That ticket says it was only for the "add-on compatibility" dialog but I see the Firefox logo during the launcher screen as well the browser after. Only if you close it and reopen again, it loads the default tor browser icon.

Aha! Do you have steps to reproduce that for me? Typically, at least older version can be found on https://dist.torproject.org/torbrowser (apart from the current one).

comment:4 Changed 4 years ago by cypherpunks

It happens only after an automatic update so I'm assuming these steps should work:

1) Download TBB full version, not incremental (try 5.07 nix x64 package)
2) Load it, check for TBB update using Torbutton and update when it asks you to
3) After downloading the update, prompt will come up to apply then restart tor browser, click restart
4) It should restart, showing addon compatability window first, then launcher then loads the browser (so now you're at your default homepage)

During all 3 screens and even continuing to use the browser right after a restart, it shows the Firefox logo instead of the default Green globe.

comment:5 Changed 4 years ago by gk

Hm, I am not able to reproduce this. :(

comment:6 Changed 4 years ago by mcs

Cc: mcs added

I thought there was already a ticket for this issue but I cannot find one. Using TB 5.5 and updating to 5.5.1, I was able to reproduce this on an Ubuntu 14.04 LTS system.

Running ./start-to-browser.desktop --register-app did not add the Tor Browser icon to my Unity launcher, and when I started Tor Browser I saw a '?' icon in the launcher. Ignoring that problem for now, after updating via "Check for Tor Browser Update" and restarting, I found that my Firefox icon (which was already on my launcher) was active and was associated with Tor Browser. Restarting again made things switch back to the '?' icon.

I am almost certain this bug occurs because the --class "Tor Browser" command line argument does not get passed to the firefox binary when it is restarted after an update has been applied. The class may also be lost during other restarts, e.g., after installing an add-on. The cleanest solution might be to bake the WM_CLASS value into the browser via a Firefox patch. I think we would need to add a call to gdk_set_program_class().

comment:7 in reply to:  6 ; Changed 4 years ago by cypherpunks

Replying to mcs:

I thought there was already a ticket for this issue but I cannot find one. Using TB 5.5 and updating to 5.5.1, I was able to reproduce this on an Ubuntu 14.04 LTS system.

Running ./start-to-browser.desktop --register-app did not add the Tor Browser icon to my Unity launcher, and when I started Tor Browser I saw a '?' icon in the launcher. Ignoring that problem for now, after updating via "Check for Tor Browser Update" and restarting, I found that my Firefox icon (which was already on my launcher) was active and was associated with Tor Browser. Restarting again made things switch back to the '?' icon.

I am almost certain this bug occurs because the --class "Tor Browser" command line argument does not get passed to the firefox binary when it is restarted after an update has been applied. The class may also be lost during other restarts, e.g., after installing an add-on. The cleanest solution might be to bake the WM_CLASS value into the browser via a Firefox patch. I think we would need to add a call to gdk_set_program_class().

This is the same solution you suggested for #17891 (and I'm pretty sure it would fix that issue, not sure about this one).

comment:8 in reply to:  7 Changed 4 years ago by mcs

Replying to cypherpunks:

This is the same solution you suggested for #17891 (and I'm pretty sure it would fix that issue, not sure about this one).

Thanks! That is the other ticket I was think of (even if I could not remember the details).

comment:9 Changed 3 years ago by mcs

Cc: brade added
Owner: changed from tbb-team to mcs
Status: needs_informationassigned

comment:10 Changed 3 years ago by gk

Cc: rugk added

Baking in the proper WM_CLASS value would help as well for users having e.g. the stable and the hardened version installed side-by-side. See #20313 for such a scenario.

comment:11 Changed 3 years ago by rugk

BTW I've also opened an upstream issue for this "restart and --class gets lost" issue as it also affectes Firefox: https://bugzilla.mozilla.org/show_bug.cgi?id=1308719 (You can vote this up :). )

comment:12 in reply to:  11 Changed 2 years ago by cypherpunks

Keywords: tbb-branding added

Replying to rugk:

BTW I've also opened an upstream issue for this "restart and --class gets lost" issue as it also affectes Firefox: https://bugzilla.mozilla.org/show_bug.cgi?id=1308719 (You can vote this up :). )

RESOLVED DUPLICATE of https://bugzilla.mozilla.org/show_bug.cgi?id=849571

comment:13 Changed 2 years ago by mcs

Cc: eezacque added

I resolved #24142 as a duplicate. An additional comment from that ticket: "This is confusing and possibly dangerous, because the user cannot distinguish between secure Tor and insecure Firefox!"

comment:14 Changed 2 years ago by cypherpunks

This seems to happen after an update with Gnome Shell.

Note: See TracTickets for help on using tickets.