Opened 8 years ago

Closed 7 years ago

Last modified 6 years ago

#1820 closed defect (not a bug)

make distcheck fails for --disable-asciidoc

Reported by: ln5 Owned by: ln5
Priority: Very Low Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Keywords: tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

make[4]: Entering directory `/u/src/tor/linus/tor/tor-0.2.2.14-alpha-dev/_build/doc'
make[4]: * No rule to make target tor.1.txt', needed by tor.1.in'. Stop.

Child Tickets

Change History (8)

comment:1 Changed 8 years ago by nickm

An interesting issue. From a certain point of view, --disable-asciidoc doesn't make any sense for use with "make distcheck", since without asciidoc you _can't_ in fact generate the .1.in files that need to go in a proper Tor source distribution, so it's no surprise when a later attempt to build that distribution fails.

But of course, "make distcheck" isn't just for checking if you can make a good distribution vis-a-vis documentation; it's also good for checking lots of other build issues, and it would be neat if it mostly worked without asciidoc.

To fix the immediate issue here, all we have to do is make the .1.txt files go into EXTRA_DIST whether USE_ASCIIDOC is true or not. But make distcheck with --disable-asciidoc will still fail, since the .1.in files won't exist in the distribution, and the test build won't know to use --disable-asciidoc

comment:2 Changed 8 years ago by nickm

Milestone: Tor: unspecified

comment:3 Changed 7 years ago by Sebastian

I actually think it might not be too bad, because when you run make dist with --disable-asciidoc the tarball will be useless to the average user. What are the extra tests that make distcheck does that aren't made otherwise?

comment:4 Changed 7 years ago by nickm

Basically, "distcheck" makes sure that the distribution is working: that "make dist" creates something that will indeed produce a working Tor. Ways to fail that include, as noted here, failure to include needed files in the distribution.

comment:5 Changed 7 years ago by Sebastian

So is this still a bug? It seems to me that we could only hack around the error report here by attempting to pass --disable-asciidoc to the configure during make distcheck, and if we do that then we might accidentally release a tarball without the manpages.

comment:6 in reply to:  5 Changed 7 years ago by rransom

Resolution: not a bug
Status: newclosed

Replying to Sebastian:

So is this still a bug?

No.

comment:7 Changed 6 years ago by nickm

Keywords: tor-relay added

comment:8 Changed 6 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.