Opened 4 years ago

Closed 4 years ago

#18201 closed defect (not a bug)

dom.storage.enabled value

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

dom.storage.enabled value in about:config is set to true. is this disabled or is the browser really allowing dom storage?

i've also read of tbb about:config values that are disabled in another way like torbutton but still shows as enabled in about:config. why the confusion in leaving it as enabled in about:config when it is disabled in reality or vice-versa?

like "camera.control.face_detection.enabled - true", is it really enabled or disabled at a deeper level?

Child Tickets

Change History (1)

comment:1 Changed 4 years ago by gk

Resolution: not a bug
Status: newclosed

DOM Storage is allowed but bound to the URL bar domain. A look into our design document might help here: https://www.torproject.org/projects/torbrowser/design/. The camera pref is for a feature that is not for desktop Firefox.

Note: See TracTickets for help on using tickets.