Opened 3 years ago

Closed 3 years ago

#18210 closed defect (invalid)

Tor Browser 5.5 does not start on Ubuntu wily

Reported by: doirya Owned by: boklm
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Major Keywords: TorBrowserTeam201602
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Since the Update to TBB 5.5, I only get "Tor unexpectedly exited" when starting. The only error I find in the logs is

/home/doirya/.local/opt/tor-browser_en-US/Browser/TorBrowser/Tor/tor: symbol lookup error: /home/doirya/.local/opt/tor-browser_en-US/Browser/TorBrowser/Tor/tor: undefined symbol: evutil_secure_rng_set_urandom_device_file

This may be related to libevent in ubuntu being only at version 2.0.21, while the function above apparently was added in 2.0.22.

Child Tickets

Attachments (1)

tbb.log (401 bytes) - added by doirya 3 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 3 years ago by gk

Status: newneeds_information

Are you using our official Tor Browser (https://dist.torproject.org/torbrowser/5.5/)? That should contain all you need. Tor Browser is not supposed to use the libraries of your Linux distribution which is why we use the start-tor-browser script to set LD_LIBRARY_PATH to the path containing e.g. libevent 2.0.22. How are you starting your Tor Browser?

comment:2 Changed 3 years ago by doirya

I had only used the "check for updates" function of my 5.0.? TBB.
Tried again using https://www.torproject.org/dist/torbrowser/5.5/tor-browser-linux64-5.5_en-US.tar.xz:

$ rm -rf tor-browser_en-US/
$ tar xfJ ~/Downloads/tor-browser-linux64-5.5_en-US.tar.xz
$ cd tor-browser_en-US/
$ ./start-tor-browser.desktop --log $(readlink -f tbb.log)

Still get the same error. I'm attaching the full log just in case.

Changed 3 years ago by doirya

Attachment: tbb.log added

comment:3 Changed 3 years ago by gk

Which Ubuntu version are you on?

If you add "echo $LD_LIBRARY_PATH" on line 348 in start-tor-browser (which is in the Browser subdirectory) what path (if any) is shown if you start Tor Browser with ./start-tor-browser.desktop --debug?

comment:4 Changed 3 years ago by doirya

The version used is Ubuntu wily (15.10) as mentioned in the title.
I've added the echo statement and I get

/home/doirya/.local/opt/tor-browser_en-US/Browser/TorBrowser/Tor/

Last edited 3 years ago by doirya (previous) (diff)

comment:5 in reply to:  4 Changed 3 years ago by gk

Replying to doirya:

The version used is Ubuntu wily (15.10) as mentioned in the title.

Ah, okay, sorry.

I've added the echo statement and I get

/home/doirya/.local/opt/tor-browser_en-US/Browser/TorBrowser/Tor/

Interesting. Just to be sure this happens when starting the build in your .local/opt dir and the path is adapted accordingly if you are using the one in comment:2?

comment:6 Changed 3 years ago by doirya

I only have one copy of TBB (in ~/.local/opt). Probably should have put

$ cd ~/.local/opt

As first command in comment:2.

comment:7 Changed 3 years ago by gk

Keywords: TorBrowserTeam201602 added

comment:8 Changed 3 years ago by gk

Owner: changed from erinn to boklm
Status: needs_informationassigned

boklm: could you take a look at this one and try to figure out what is going on?

comment:9 Changed 3 years ago by gk

FWIW I have no such problems testing on a 12.04 or a 14.04 machine.

comment:10 Changed 3 years ago by doirya

Hmkay, I think I figured it out. It appears to be an apparmor bug:
I had written a profile for TBB a while ago but set it to "complain" mode. This is not supposed to break anything but merely log policy violations. There are no apparmor-related log entries in dmesg. However, when I disable the profile (using aa-disable) TBB starts as expected. Turning is back to complain mode (aa-complain) restores the behavior described above.
Sorry for not ruling that out earlier.

comment:11 Changed 3 years ago by gk

Resolution: not a bug
Status: assignedclosed

No worries, glad it got resolved.

comment:12 Changed 3 years ago by bugzilla

not a bug

means that

Tor Browser 5.5 does not start on Ubuntu wily

is ok. It's not a bug.
But TS says that TBB works now.
Propose closing as INVALID.

(And is Component selected right?)

Last edited 3 years ago by bugzilla (previous) (diff)

comment:13 Changed 3 years ago by gk

Resolution: not a bug
Status: closedreopened

comment:14 Changed 3 years ago by gk

Resolution: invalid
Status: reopenedclosed
Note: See TracTickets for help on using tickets.