Opened 2 years ago

Closed 7 months ago

#18222 closed defect (not a bug)

Tor Browser sets different Guard for one of the tabs when goes crazy

Reported by: bugzilla Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

New tabs show nothing (old bug). Some previously opened tabs show default Guard in France, after refresh too, after new circuit - nothing. But when new tab was opened from previously opened tab by 'Search Disconnect for', it lags a lot to connect and then shows Guard in Russian Federation!
What’s going on here?

Child Tickets

Change History (9)

comment:1 Changed 2 years ago by bugzilla

Priority: MediumVery High
Severity: MajorCritical
Summary: Circuit visualizer shows different Guard for one tab!Circuit visualizer shows different Guard for one of the tabs!

Browser Console confirms Guard reselection!
Ordinary tabs continue to use the default Guard.
'Open in a New Tab' for the video and etc leads to the same behavior sometimes.

comment:2 Changed 2 years ago by cypherpunks

I could not reproduce this using "context menu > Search Disconnect for ...".

What's this video you talk about?

comment:4 Changed 21 months ago by bugzilla

Is this a personal american spam or what?

comment:5 Changed 20 months ago by bugzilla

Summary: Circuit visualizer shows different Guard for one of the tabs!Tor Browser sets different Guard for one of the tabs when goes crazy

Takes part in ticket:18080#comment:14.

comment:8 Changed 14 months ago by cypherpunks

Right now I'm observing two tabs with separate guard for each on TBB 7.0a3. "New Tor Circuit for this Site" changes circuits as usual, preserving guards on both tabs.

comment:12 Changed 8 months ago by cypherpunks

Wow, what made this ticket attract so many spammers? :)

comment:13 in reply to:  12 Changed 7 months ago by qbi

Replying to cypherpunks:

Wow, what made this ticket attract so many spammers? :)

I deleted all the spam comments and hope they won't come back and spam again. ;)

comment:14 Changed 7 months ago by teor

Priority: Very HighMedium
Severity: CriticalNormal

It's normal for tor to use more than one guard in some circumstances, particularly if the connection to one of the primary guards is unreliable.

I don't think this is even a bug.

comment:15 in reply to:  14 Changed 7 months ago by gk

Resolution: not a bug
Status: newclosed

Replying to teor:

It's normal for tor to use more than one guard in some circumstances, particularly if the connection to one of the primary guards is unreliable.

I don't think this is even a bug.

I agree.

Note: See TracTickets for help on using tickets.