Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#18225 closed defect (duplicate)

Tor button control parser broken

Reported by: cypherpunks Owned by:
Priority: Medium Milestone:
Component: Applications/Torbutton Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The tor button control parser (tor-control-port.js) doesn't properly parse multi line responses. The logic to recognize the last line of a multi line response is broken.

This is probably the cause of bug:
https://trac.torproject.org/projects/tor/ticket/16990

Child Tickets

Change History (2)

comment:1 Changed 4 years ago by gk

Resolution: duplicate
Status: newclosed

Let's fix that there while we are getting rid of that bug. Closing this one as a duplicate of #16990.

comment:2 Changed 4 years ago by cypherpunks

The reason for filing this bug was that 16990 can be fixed with addressing the root cause, just fixing the parsing for 'GETINFO circuit-status'. The parsing should be able to handle all multi line control responses.

Note: See TracTickets for help on using tickets.