Opened 4 years ago

Closed 3 years ago

#18229 closed defect (wontfix)

Tor Browser fails on Windows 8.1 when not run as Administrator

Reported by: Merlin Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: mcs Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Windows 8.1 x64 Product ID 00178-11238-67300-AB400on Lenovo T60 3.0 GB ram T7200 @2.00GHZ processor always gives the following error:

[Wed Feb 3 22:41:10 2016] Tor Software Error - The Tor software encountered an internal bug. Please report the following error message to the Tor developers at bugs.torproject.org: "getinfo_helper_dir(): Bug: control.c:1676: getinfo_helper_dir: Assertion md->body failed; aborting.

Child Tickets

TicketStatusOwnerSummaryComponent
#18232closedFIX- Select a component

Change History (7)

comment:1 Changed 4 years ago by cypherpunks

What tor version?

comment:2 Changed 4 years ago by teor

Component: TorTor Browser
Owner: set to tbb-team

Merlin said on #18232:
"In Windows 8.1 Tor versions 5.0.1 through 5.5 work as expected see.

IF one right clicks on the shortcut and selects "Run as Administrator""

This looks like a Tor Browser ticket, I suspect it happens when tor can't write the cached-microdescs file.

comment:3 Changed 4 years ago by teor

Summary: error messaggeTor Browser fails on Windows 8.1 when not run as Administrator

comment:4 Changed 4 years ago by mcs

Cc: mcs added
Status: newneeds_information

I am setting the status of this ticket to Needs Information.
How and where was Tor Browser installed?

Tor Browser is designed as a portable package and therefore requires write access to its files. Please try installing it as the same user who will use it and place the Tor Browser folder in a location where that user has full access to the files, including write access.

A side note: if the Tor Software Error that was encountered was in fact caused by a lack of write access, it would be good to modify tor to log a better error message.

comment:5 Changed 4 years ago by cypherpunks

tor can't write the cached-microdescs file

and warns about bug then it's bug.

comment:6 Changed 4 years ago by cypherpunks

[Wed Feb 3 22:41:10 2016] Tor Software Error - The Tor software encountered an internal bug. Please report the following error message to the Tor developers at bugs.torproject.org: "getinfo_helper_dir(): Bug: control.c:1676: getinfo_helper_dir: Assertion md->body failed; aborting.

This is report from 0.2.3.x, non actual since 0.2.4.x

This is report for version prior TorBrowser 3.0.

comment:7 Changed 3 years ago by teor

Resolution: wontfix
Status: needs_informationclosed

Given these are permissions issues on old versions of tor and tor browser, I think we can close this one.

Note: See TracTickets for help on using tickets.