Opened 4 years ago

Closed 4 years ago

#18282 closed defect (duplicate)

Exonerator should set a Content-Type

Reported by: garrettr Owned by: karsten
Priority: Medium Milestone:
Component: Metrics/ExoneraTor Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

https://exonerator.torproject.org/ does not set a Content-Type (either in a header or in an equivalent meta tag), but it does set X-Content-Type-Options: nosniff. This prevents Chrome/Chromium and IE from sniffing the Content-Type, so the browser just renders the HTML source code as text. Firefox does not interpret this particular X-header, so it sniffs the Content Type type and renders the page as HTML, which seems to be the intended behavior.

Child Tickets

Attachments (1)

Screen Shot 2016-02-08 at 11.19.09 AM.png (565.5 KB) - added by garrettr 4 years ago.
Exonerator in Chrome

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by garrettr

Exonerator in Chrome

comment:1 Changed 4 years ago by arma

Component: - Select a componentExoneraTor

comment:2 Changed 4 years ago by arma

Owner: set to karsten
Status: newassigned

comment:3 Changed 4 years ago by garrettr

This is accidentally a dupe of #18281.

comment:4 Changed 4 years ago by karsten

Resolution: duplicate
Status: assignedclosed

Fixed in #18281, I think. Resolving.

Note: See TracTickets for help on using tickets.