Opened 4 years ago

Closed 3 years ago

#18317 closed defect (not a bug)

Something after refresh of timeline

Reported by: bugzilla Owned by: qbi
Priority: Medium Milestone:
Component: Internal Services/Service - trac Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Just refreshed (F5) https://trac.torproject.org/projects/tor/timeline
and this:

Traceback (most recent call last):

File "/usr/lib/python2.7/dist-packages/trac/web/api.py", line 514, in send_error

data, 'text/html')

File "/usr/lib/python2.7/dist-packages/trac/web/chrome.py", line 968, in render_template

message = Markup(req.session.pop('chrome.%s.%d'

File "/usr/lib/python2.7/dist-packages/trac/web/api.py", line 316, in getattr

value = self.callbacks[name](self)

File "/usr/lib/python2.7/dist-packages/trac/web/main.py", line 268, in _get_session

return Session(self.env, req)

File "/usr/lib/python2.7/dist-packages/trac/web/session.py", line 200, in init

if req.authname == 'anonymous':

File "/usr/lib/python2.7/dist-packages/trac/web/api.py", line 316, in getattr

value = self.callbacks[name](self)

File "/usr/lib/python2.7/dist-packages/trac/web/main.py", line 135, in authenticate

authname = authenticator.authenticate(req)

File "build/bdist.linux-x86_64/egg/acct_mgr/util.py", line 82, in wrap

return func(self, *args, kwds)

File "build/bdist.linux-x86_64/egg/acct_mgr/web_ui.py", line 374, in authenticate

return auth.LoginModule.authenticate(self, req)

File "/usr/lib/python2.7/dist-packages/trac/web/auth.py", line 91, in authenticate

req.incookietrac_auth?)

File "build/bdist.linux-x86_64/egg/acct_mgr/web_ui.py", line 448, in _get_name_for_cookie

name = auth.LoginModule._get_name_for_cookie(self, req, cookie)

File "/usr/lib/python2.7/dist-packages/trac/web/auth.py", line 238, in _get_name_for_cookie

name = self._cookie_to_name(req, cookie)

File "/usr/lib/python2.7/dist-packages/trac/web/auth.py", line 234, in _cookie_to_name

for name, in self.env.db_query(sql, args):

File "/usr/lib/python2.7/dist-packages/trac/db/api.py", line 121, in execute

with self as db:

File "/usr/lib/python2.7/dist-packages/trac/db/api.py", line 174, in enter

db = self.dbmgr.get_connection(readonly=True)

File "/usr/lib/python2.7/dist-packages/trac/db/api.py", line 262, in get_connection

db = self._cnx_pool.get_cnx(self.timeout or None)

File "/usr/lib/python2.7/dist-packages/trac/db/pool.py", line 213, in get_cnx

return _backend.get_cnx(self._connector, self._kwargs, timeout)

File "/usr/lib/python2.7/dist-packages/trac/db/pool.py", line 134, in get_cnx

raise TimeoutError(errmsg)

TimeoutError: Unable to get database connection within 0 seconds. (OperationalError: could not connect to server:

Connection refused

Is the server running on host "drobovi.torproject.org" (2620:0:6b0:b:1a1a:0:26e5:4803) and accepting
TCP/IP connections on port 5432?

could not connect to server: Connection refused

Is the server running on host "drobovi.torproject.org" (38.229.72.3) and accepting
TCP/IP connections on port 5432?

)

Child Tickets

Change History (3)

comment:1 Changed 4 years ago by arma

Looks like a temporary hiccup, e.g. because one of the machines involved was updating?

Works for me now. I suggest closing the ticket, alas.

comment:2 Changed 4 years ago by bugzilla

It was filed for admins only.
(Maybe, there is something valuable for them?)

comment:3 Changed 3 years ago by qbi

Resolution: not a bug
Status: newclosed

Thanks for your message. As arma wrote it was a temporary hiccup. So I'll close the ticket.

Note: See TracTickets for help on using tickets.